summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-28 23:41:03 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:20:59 +0000
commitb39b38a8d8cd548b600ecd8e50702b56570d054a (patch)
tree008b06a30434ef7e7430bb26cc8fd8afccc9d2cb
parentbcfbb05fdb0731166a9b49aff5be32025ba92695 (diff)
downloadguix-b39b38a8d8cd548b600ecd8e50702b56570d054a.tar.gz
gnu: Add go-github-com-logrusorgru-aurora-v4.
* gnu/packages/golang-xyz.scm (go-github-com-logrusorgru-aurora-v4): New variable.

Change-Id: I38956184e5b82865b8df0b8c7a7b6a434be1b8a4
-rw-r--r--gnu/packages/golang-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 291389a893..00c0c11034 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1405,6 +1405,28 @@ Printf/Sprintf etc.")
      (list
       #:import-path "github.com/logrusorgru/aurora/v3"))))
 
+(define-public go-github-com-logrusorgru-aurora-v4
+  (package
+    (inherit go-github-com-logrusorgru-aurora)
+    (name "go-github-com-logrusorgru-aurora-v4")
+    (version "4.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/logrusorgru/aurora")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0a4w4p0sl5hwa9fridk7s023sjcis8qf1k8fm3g5qar58vxzlh9w"))
+       (file-name (git-file-name name version))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.19
+      #:import-path "github.com/logrusorgru/aurora/v3"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))))
+
 (define-public go-github-com-kballard-go-shellquote
   ;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
   (let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")