summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:06:48 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commitb7e2da3cdad31f6cefd6221f9893656509d27f53 (patch)
tree40561e9fc1a79d278c35ae83200dcad78e638371
parentfbe4941c6e19aab05ba7b32988bc75c7d5b698cd (diff)
downloadguix-b7e2da3cdad31f6cefd6221f9893656509d27f53.tar.gz
gnu: Add go-github-com-hashicorp-go-retryablehttp.
* gnu/packages/golang-web.scm (go-github-com-hashicorp-go-retryablehttp): New variable.

Change-Id: I60bee5b1ae3cda325cc1be4636766f5ac65a5555
-rw-r--r--gnu/packages/golang-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c2406d6914..5f9ff53793 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2487,6 +2487,35 @@ the Go standard library, but returns a client that does not share any state
 with other clients.")
     (license license:mpl2.0)))
 
+(define-public go-github-com-hashicorp-go-retryablehttp
+  (package
+    (name "go-github-com-hashicorp-go-retryablehttp")
+    (version "0.7.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hashicorp/go-retryablehttp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11bqzz3244vpa91l5bx8pp5pajbcg4qxrl8ic2x0qgwbrjfz362x"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/hashicorp/go-retryablehttp"))
+    (propagated-inputs
+     (list go-github-com-hashicorp-go-hclog
+           go-github-com-hashicorp-go-cleanhttp))
+    (home-page "https://github.com/hashicorp/go-retryablehttp")
+    (synopsis "Retryable HTTP client in Golang")
+    (description
+     "Package retryablehttp provides a familiar HTTP client interface with
+automatic retries and exponential backoff.  It is a thin wrapper over the
+standard @code{net/http} client library and exposes nearly the same public
+API.")
+    (license license:mpl2.0)))
+
 (define-public go-github-com-hjson-hjson-go-v4
   (package
     (name "go-github-com-hjson-hjson-go-v4")