summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 22:07:35 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:35:20 +0100
commitb8558c740e202399b4184dba4c8e2c149820b753 (patch)
tree718e2f05be58f662760c8c808cd130a63334bc17
parentd4032419ddc4caca20f9ff58cb44994f0d5cba8f (diff)
downloadguix-b8558c740e202399b4184dba4c8e2c149820b753.tar.gz
gnu: go-github-com-fatih-color: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-fatih-color): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/bioinformatics.scm: Add (gnu packages golang-xyz) module.

Change-Id: I302327d3426100d7984e6086726396e9fe7f7468
-rw-r--r--gnu/packages/bioinformatics.scm1
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm25
3 files changed, 29 insertions, 25 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 452ec1d829..448ea5d6de 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -96,6 +96,7 @@
   #:use-module (gnu packages golang-build)
   #:use-module (gnu packages golang-check)
   #:use-module (gnu packages golang-compression)
+  #:use-module (gnu packages golang-xyz)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages graph)
   #:use-module (gnu packages graphics)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 71303be53d..68195014eb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2019-2021 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
@@ -1115,6 +1116,33 @@ for @code{Set}, @code{Get}, @code{Delete} and @code{Len}.")
 Alphanum Algorithm} developed by Dave Koelle in Go.")
     (license license:bsd-3)))
 
+(define-public go-github-com-fatih-color
+  (package
+    (name "go-github-com-fatih-color")
+    (version "1.16.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fatih/color")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15689x103gy9q7g7623rlvhwrw27p079ardapmrrag0sdwrx5bq2"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/fatih/color"))
+    (propagated-inputs
+     (list go-github-com-mattn-go-colorable
+           go-github-com-mattn-go-isatty))
+    (home-page "https://pkg.go.dev/github.com/fatih/color")
+    (synopsis "Print colored text in Go")
+    (description
+     "This package provides an ANSI color package to output colorized or SGR
+defined output to the standard output.")
+    (license license:expat)))
+
 (define-public go-github-com-gabriel-vasile-mimetype
   (package
     (name "go-github-com-gabriel-vasile-mimetype")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fb558c1b9c..d5b8a67b97 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6140,31 +6140,6 @@ filters for Go.")
 @code{mbox} files.")
     (license license:expat)))
 
-(define-public go-github-com-fatih-color
-  (package
-    (name "go-github-com-fatih-color")
-    (version "1.16.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/fatih/color")
-                     (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "15689x103gy9q7g7623rlvhwrw27p079ardapmrrag0sdwrx5bq2"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/fatih/color"))
-    (propagated-inputs
-     (list go-github-com-mattn-go-colorable
-           go-github-com-mattn-go-isatty))
-    (synopsis "Print colored text in Go")
-    (description "This package provides an ANSI color package to output
-colorized or SGR defined output to the standard output.")
-    (home-page "https://pkg.go.dev/github.com/fatih/color")
-    (license license:expat)))
-
 (define-public go-github-com-google-go-cmp-cmp
   (package
     (name "go-github-com-google-go-cmp-cmp")