summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 01:12:44 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:12 +0200
commitbbc22b984dfcaa054c64399a82cd6876cad13fd8 (patch)
tree365d48a83082d6b6c0122b66dd815017170850f8
parentebc6a59c63a0d5d9734a89b01583d6eb002f4af2 (diff)
downloadguix-bbc22b984dfcaa054c64399a82cd6876cad13fd8.tar.gz
gnu: Add emacs-counsel-tramp.
* gnu/packages/emacs-xyz.scm (emacs-counsel-tramp): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dd9667d1e6..f6d9944a17 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15055,6 +15055,29 @@ nodes, and more.")
 well as an option for visually flashing evaluated s-expressions.")
     (license license:gpl3+)))
 
+(define-public emacs-counsel-tramp
+  (package
+    (name "emacs-counsel-tramp")
+    (version "0.6.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/masasam/emacs-counsel-tramp")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0nz0733x2b9b5nkwivvhv5c8747dng451na1sdfbkx5x9fjs5gc7"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-ivy" ,emacs-ivy)))
+    (home-page "https://github.com/masasam/emacs-counsel-tramp")
+    (synopsis "Ivy interface for TRAMP")
+    (description "This package allows @code{ivy-mode} to display and filter
+SSH servers.")
+    (license license:gpl3+)))
+
 (define-public emacs-semantic-refactor
   ;; The last release, 0.5, was made on 2015-07-26 and there have been 47
   ;; commits since then.