summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-24 14:19:47 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:09:41 +0100
commitbbd0a46127cd673f7d1d1507e33b8486a9afde3a (patch)
treeaa487db0204ac53d53e2f2e098e072517b1746b8
parent560a6c4962276aaba181e966b0b07e014b7f55ac (diff)
downloadguix-bbd0a46127cd673f7d1d1507e33b8486a9afde3a.tar.gz
gnu: Remove ocaml4.07-frontc.
* gnu/packages/ocaml.scm (ocaml4.07-frontc): Remove variable.
(ocaml-frontc)[properties]: Remove variant.

Change-Id: I52bf626af56d05e6230365825b944240cc523cdc
-rw-r--r--gnu/packages/ocaml.scm42
1 files changed, 1 insertions, 41 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c8f53c193c..8f8758ed59 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1638,8 +1638,7 @@ for speed and space economy.")
              (for-each make-file-writable (find-files "." ".")))))))
     (native-inputs
      (list ocaml-menhir ocaml-odoc))
-    (properties `((upstream-name . "FrontC")
-                  (ocaml4.07-variant . ,(delay ocaml4.07-frontc))))
+    (properties `((upstream-name . "FrontC")))
     (home-page "https://www.irit.fr/FrontC")
     (synopsis "C parser and lexer library")
     (description "FrontC is an OCAML library providing a C parser and lexer.
@@ -1648,45 +1647,6 @@ It provides support for ANSI C syntax, old-C K&R style syntax and the standard
 GNU CC attributes.  It provides also a C pretty printer as an example of use.")
     (license license:lgpl2.1)))
 
-(define-public ocaml4.07-frontc
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-frontc)
-      (version "3.4.2")
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/mirage/ocaml-base64")
-                       (commit (string-append
-                                 "V_" (string-join (string-split version #\.) "_")))))
-                (file-name (git-file-name "ocaml-frontc" version))
-                (sha256
-                 (base32
-                  "0k7jk9hkglnkk27s62xl493jyqc017gyvwqb1lyc0ywbb001s102"))))
-      (build-system ocaml-build-system)
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (delete 'configure)
-           (add-after 'install 'install-meta
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let ((out (assoc-ref outputs "out")))
-                 (with-output-to-file
-                     (string-append out "/lib/ocaml/frontc/META")
-                   (lambda _
-                     (display
-                      (string-append
-                       "description = \"Parser for the C language\"
-version = \"" ,version "\"
-requires = \"unix\"
-archive(byte) = \"frontc.cma\"
-archive(native) = \"frontc.cmxa\""))))
-                 (symlink (string-append out "/lib/ocaml/frontc")
-                          (string-append out "/lib/ocaml/FrontC"))))))
-         #:make-flags ,#~(list (string-append "PREFIX=" #$output)
-                               "OCAML_SITE=$(LIB_DIR)/ocaml/")))
-      (properties '()))))
-
 (define-public ocaml-qcheck
   (package
     (name "ocaml-qcheck")