summary refs log tree commit diff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2023-08-23 20:08:05 -0400
committerEfraim Flashner <efraim@flashner.co.il>2023-09-08 09:05:57 +0300
commitbce0fe8293a15331ed8b4e9a76354988f10e1ef5 (patch)
tree736abe154815a6614c8e0c15674fae11081fe3ed
parent0a69961953307040f4c3994ae09286768ce67c9c (diff)
downloadguix-bce0fe8293a15331ed8b4e9a76354988f10e1ef5.tar.gz
gnu: racket: Declare OpenSSL search paths.
Otherwise, OpenSSL used via Racket fails to find certificates, e.g. when
attempting to run 'raco pkg install'.

Fixes <https://racket.discourse.group/t/2206/8>.

* gnu/packages/racket.scm (racket-minimal)[native-search-paths]: Add
$SSL_CERT_DIR and $SSL_CERT_FILE.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/racket.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index b6ab687a21..1e97f19dbb 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -29,6 +29,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix diagnostics)
   #:use-module (guix i18n)
+  #:use-module ((guix search-paths) #:select ($SSL_CERT_DIR $SSL_CERT_FILE))
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26)
   #:use-module (srfi srfi-34)
@@ -553,6 +554,7 @@ used to build the name of the resulting store item."
             "base" %racket-origin
             '(("base" "pkgs/base")
               ("racket-lib" "pkgs/racket-lib")))))
+    (native-search-paths (list $SSL_CERT_DIR $SSL_CERT_FILE))
     (build-system gnu-build-system)
     (arguments
      ;; Here and for the `racket` package, we're using #:configure-flags