summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 17:15:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:04 +0100
commitbd86f7dbdf366c52214cda824246b2e642d32a96 (patch)
treef19116b495011a1d6e327c7a11601b367ca0fbe6
parenta0bdbf8b4129899b5f00335e3412a6752a26f816 (diff)
downloadguix-bd86f7dbdf366c52214cda824246b2e642d32a96.tar.gz
gnu: chez-fmt: Return #t from all phases.
* gnu/packages/chez.scm (chez-fmt)[arguments]: Always return #t from phases.
Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/chez.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index c99f8a8bab..cbbca34c1a 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -515,10 +515,10 @@ syntax, with various aliases for commonly used patterns.")
          (replace 'configure ,chez-configure)
          (replace 'build
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
-             (zero? (apply system* "make" "chez-build" make-flags))))
+             (apply invoke "make" "chez-build" make-flags)))
          (replace 'install
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
-             (zero? (apply system* "make" "chez-install" make-flags)))))))
+             (apply invoke "make" "chez-install" make-flags))))))
     (home-page "http://synthcode.com/scheme/fmt")
     (synopsis "Combinator formatting library for Chez Scheme")
     (description "This package provides a library of procedures for