summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-04 18:17:11 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-04 22:58:57 +0100
commitbeaff4a8a991fc04b5298d86be70490a718b80dd (patch)
treeeed596d270fc0516a77d9529b916e93fb55c3f08
parent6c58a06e796962720c02ba50651d26acfbcbd269 (diff)
downloadguix-beaff4a8a991fc04b5298d86be70490a718b80dd.tar.gz
gnu: python-flake8: Update to 3.7.7.
* gnu/packages/python-xyz.scm (python-flake8): Update to 3.7.7.
[propagated-inputs]: Add PYTHON-ENTRYPOINTS.
(python2-flake8)[propagated-inputs]: Add PYTHON2-TYPING.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7d4498f285..af3c5a4667 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5751,13 +5751,13 @@ complexity of Python source code.")
 (define-public python-flake8
   (package
     (name "python-flake8")
-    (version "3.6.0")
+    (version "3.7.7")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "flake8" version))
               (sha256
                (base32
-                "0w0nprx22rbvrrkbfx9v5jc5gskbm08g219l7r8wai8zfswgadba"))))
+                "0qg6zggqigrd4k3gv88shd1a27d0cwgfql8vfiq2c7rl7w3rd6c5"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -5770,6 +5770,7 @@ complexity of Python source code.")
              #t)))))
     (propagated-inputs
      `(("python-pycodestyle" ,python-pycodestyle)
+       ("python-entrypoints" ,python-entrypoints)
        ("python-pyflakes" ,python-pyflakes)
        ("python-mccabe" ,python-mccabe)))
     (native-inputs
@@ -5790,6 +5791,7 @@ complexity of Python source code.")
       (propagated-inputs
        `(("python2-configparser" ,python2-configparser)
          ("python2-enum34" ,python2-enum34)
+         ("python2-typing" ,python2-typing)
           ,@(package-propagated-inputs base))))))
 
 ;; python-hacking requires flake8 <2.6.0.