summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:44:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:18 +0200
commitbffccff762e25e3e17dabce02fdbcb878d5979e6 (patch)
tree8c194e2219b0b15ffb56cba230856810792acecf
parent5888a93b013e113eecffd79ea400db40b3e6d844 (diff)
downloadguix-bffccff762e25e3e17dabce02fdbcb878d5979e6.tar.gz
gnu: Add texlive-revquantum.
* gnu/packages/tex.scm (texlive-revquantum): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3bec8103fe..ab333d4b45 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5839,6 +5839,31 @@ method description path parameter request body and content type response body,
 content type and status code.")
     (license license:lppl1.3c)))
 
+(define-public texlive-revquantum
+  (package
+    (name "texlive-revquantum")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/revquantum/"
+                   "source/latex/revquantum/"
+                   "tex/latex/revquantum/")
+             (base32
+              "00wac9xjzx9mw6vxd3wnjyb1f8c1661s2zwvd4d0r337ccs6jqbl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/revquantum")
+    (synopsis
+     "Hacks to make writing quantum papers for revtex4-1 less painful")
+    (description
+     "This package provides a number of useful hacks to solve common
+annoyances with the @code{revtex4-1} package, and to define notation in common
+use within quantum information.  In doing so, it imports and configures
+a number of commonly-available and used packages, and where reasonable,
+provides fallbacks.  It also warns when users try to load packages which are
+known to be incompatible with @code{revtex4-1}.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")