summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-22 12:21:38 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-22 12:22:31 +0200
commitc130c94284bc8fc812368e2a50f9fbc058ef1f2d (patch)
tree273b1d728c4af346c5ef68e33acf39424ee4bb7a
parent2a15e9276686b00f302be40216c6e862884cb20b (diff)
downloadguix-c130c94284bc8fc812368e2a50f9fbc058ef1f2d.tar.gz
gnu: libpeas: Update to 1.30.0.
* gnu/packages/gnome.scm (libpeas): Update to 1.30.0.
[arguments]: Set XDG_CACHE_HOME and XDG_CONFIG_HOME variables to fix the tests.
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f7464015f0..b23fe4a662 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3086,7 +3086,7 @@ some form of information without getting in the user's way.")
 (define-public libpeas
   (package
     (name "libpeas")
-    (version "1.28.0")
+    (version "1.30.0")
     (source
      (origin
       (method url-fetch)
@@ -3095,7 +3095,7 @@ some form of information without getting in the user's way.")
                           name "-" version ".tar.xz"))
       (sha256
        (base32
-        "05cb7drn6arc4gi02wgsvzibigi2riz5gnfnmlb0zmbfnj9ikna2"))))
+        "18xrk1c1ixlhkmykcfiafrl2am470ws687xqvjlq40zwkcp5dx8b"))))
     (build-system meson-build-system)
     (arguments
      '(#:phases
@@ -3105,6 +3105,8 @@ some form of information without getting in the user's way.")
              (let ((xorg-server (assoc-ref inputs "xorg-server"))
                    (disp ":1"))
                (setenv "DISPLAY" disp)
+               (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")
+               (setenv "XDG_CONFIG_HOME" "/tmp")
                ;; Tests require a running X server.
                (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp))
                #t))))))