summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2024-08-04 12:05:19 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2024-08-04 12:39:09 +0300
commitc29bb399d370529f307020b4ba7eeaa507ffb4d1 (patch)
tree373fa2d63eaa4225535e80848c48b227ca7ad477
parent2cc108c939555d122c9dd88591ac40eadf27b79f (diff)
downloadguix-c29bb399d370529f307020b4ba7eeaa507ffb4d1.tar.gz
gnu: Add obs-source-clone.
* gnu/packages/video.scm (obs-source-clone): New variable.

Change-Id: Id85ba2147737fe9e300911499bfd6bcdd7ce71be
-rw-r--r--gnu/packages/video.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d4fcf347f2..8fd02b1ec5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4283,6 +4283,37 @@ your host privately.")
 inputs and applications using PipeWire.")
     (license license:gpl2+)))
 
+(define-public obs-source-clone
+  (package
+    (name "obs-source-clone")
+    (version "0.1.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/exeldro/obs-source-clone")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rw0qknlkljzn4rk41g2jjnf113vald5k7kpvxvz0mpaywa6vc6j"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:modules '((guix build cmake-build-system)
+                  (guix build utils))
+      #:tests? #f ;no tests
+      #:configure-flags
+      #~(list (string-append "-DLIBOBS_INCLUDE_DIR="
+                             #$(this-package-input "obs") "/lib")
+              "-DBUILD_OUT_OF_TREE=On"
+              "-Wno-dev")))
+    (inputs (list obs qtbase-5))
+    (home-page "https://github.com/exeldro/obs-source-clone")
+    (synopsis "Plugin for OBS Studio to clone sources")
+    (description "Add source to OBS that lets you clone sources to allow
+different filters than the original.")
+    (license license:gpl2)))
+
 (define-public obs-source-copy
   (package
     (name "obs-source-copy")