summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 09:02:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commitc73f70d3d50db50c6dcd6a5fd55b448bc7e36fd7 (patch)
treebcdc5ce09a3721af20f0a49b79739e625e862956
parent5abebf71e91d16947d1ade8d4b97a76fc06e2be3 (diff)
downloadguix-c73f70d3d50db50c6dcd6a5fd55b448bc7e36fd7.tar.gz
gnu: go-github-com-mattn-go-isatty: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-isatty): Move from
here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/music.scm: Add (gnu packages golang-xyz) module.

Change-Id: Ibbab55ed60afdd5513f91dde93550b2eff7a622c
-rw-r--r--gnu/packages/golang-xyz.scm30
-rw-r--r--gnu/packages/golang.scm26
-rw-r--r--gnu/packages/music.scm1
3 files changed, 29 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 261c2c0ded..5aa2bfa169 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,9 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017-2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
-;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
@@ -1787,6 +1787,32 @@ implementing features like:
     (description "This package provides an idiomatic Go retry module.")
     (license license:expat)))
 
+(define-public go-github-com-mattn-go-isatty
+  (package
+    (name "go-github-com-mattn-go-isatty")
+    (version "0.0.20")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mattn/go-isatty")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0g63n9wpb991qnq9mn2kvd8jk1glrp6gnd851kvwz2wmzdkggiga"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/mattn/go-isatty"))
+    (propagated-inputs
+     (list go-golang-org-x-sys))
+    (home-page "https://github.com/mattn/go-isatty")
+    (synopsis "Provide @code{isatty} for Golang")
+    (description
+     "This package provides @code{isatty}, a Go module that can tell you
+whether a file descriptor points to a terminal and the type of the terminal.")
+    (license license:expat)))
+
 (define-public go-github-com-mattn-go-runewidth
   (package
     (name "go-github-com-mattn-go-runewidth")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a8f830e1d9..ed79a8b692 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4351,32 +4351,6 @@ The yaml package supports most of YAML 1.2, but preserves some behavior from
     (description "This package provides a Golang Matrix client.")
     (license license:asl2.0)))
 
-(define-public go-github-com-mattn-go-isatty
-  (package
-    (name "go-github-com-mattn-go-isatty")
-    (version "0.0.20")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/mattn/go-isatty")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0g63n9wpb991qnq9mn2kvd8jk1glrp6gnd851kvwz2wmzdkggiga"))))
-    (build-system go-build-system)
-    (propagated-inputs
-     (list go-golang-org-x-sys))
-    (arguments
-     '(#:import-path "github.com/mattn/go-isatty"))
-    (home-page "https://github.com/mattn/go-isatty")
-    (synopsis "Provide @code{isatty} for Golang")
-    (description "This package provides @code{isatty}, a Go module that can
-tell you whether a file descriptor points to a terminal and the type of the
-terminal.")
-    (license license:expat)))
-
 (define-public go-github-com-mattn-go-colorable
   (package
     (name "go-github-com-mattn-go-colorable")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 34b37ca510..0a14a11b50 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -135,6 +135,7 @@
   #:use-module (gnu packages gnunet)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
+  #:use-module (gnu packages golang-xyz)
   #:use-module (gnu packages gpodder)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages graphviz)