summary refs log tree commit diff
diff options
context:
space:
mode:
authorhapster <o.rojon@posteo.net>2024-05-26 08:42:10 +0200
committerAndreas Enge <andreas@enge.fr>2024-06-30 12:06:11 +0200
commitc7b009285ec2ab7a27747de40f28e6ecfba82922 (patch)
tree998dfcfe338194b1a1adfc2097c801872c1f510e
parent103e9db1573275118d435a15f5fbe752734cc248 (diff)
downloadguix-c7b009285ec2ab7a27747de40f28e6ecfba82922.tar.gz
gnu: mixxx: Update to 2.4.1.
* gnu/packages/music (mixxx): Update to 2.4.1.
* gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch,
gnu/packages/patches/mixxx-system-googletest-benchmark.patch: Remove
files.
* gnu/local.mk (dist_patch_DATA): Unregister patches.

Change-Id: I2ee0f2848dba7a917598a97a295d838bc0656716
Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/music.scm144
-rw-r--r--gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch25
-rw-r--r--gnu/packages/patches/mixxx-system-googletest-benchmark.patch43
4 files changed, 70 insertions, 144 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b6688fd5b3..cf6b1d61b3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1740,8 +1740,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/minisat-install.patch			\
   %D%/packages/patches/miniz-for-pytorch.patch			\
   %D%/packages/patches/mit-krb5-hurd.patch			\
-  %D%/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch	\
-  %D%/packages/patches/mixxx-system-googletest-benchmark.patch	\
   %D%/packages/patches/mpc123-initialize-ao.patch		\
   %D%/packages/patches/mpg321-CVE-2019-14247.patch		\
   %D%/packages/patches/mpg321-gcc-10.patch			\
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 540908fc8e..cb29fa5816 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -56,6 +56,7 @@
 ;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2024 Parnikkapore <poomklao@yahoo.com>
+;;; Copyright © 2024 hapster <o.rojon@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2429,7 +2430,7 @@ a JACK session.")
 (define-public mixxx
   (package
     (name "mixxx")
-    (version "2.3.6")
+    (version "2.4.1")
     (source
      (origin
        (method git-fetch)
@@ -2437,90 +2438,85 @@ a JACK session.")
              (url "https://github.com/mixxxdj/mixxx")
              (commit version)))
        (file-name (git-file-name name version))
-       (patches
-        (search-patches "mixxx-link-qtscriptbytearray-qtscript.patch"
-                        "mixxx-system-googletest-benchmark.patch"))
        (sha256
-        (base32 "1v1sza75rf2q1m0bdc0j2k53qd34m12d1573jmac3g7vvyqh5n2m"))
+        (base32 "0cfdgrxfhck6cg4j9mb2rdp06n57kca1403qw92c3pmk1y05grq4"))
        (modules '((guix build utils)))
        (snippet
         ;; Delete libraries that we already have or don't need.
         ;; TODO: try to unbundle more (see lib/).
         `(begin
-           (let ((third-parties '("apple" "benchmark" "googletest" "hidapi"
-                                  "libebur128")))
+           (let ((third-parties '("apple" "hidapi")))
              (with-directory-excursion "lib"
                (map (lambda (third-party)
-                      (delete-file-recursively third-party))
-                    third-parties)))
+                      (delete-file-recursively third-party)) third-parties)))
            #t))))
     (build-system qt-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; Tests need a running X server.
-         (add-before 'check 'prepare-x-for-test
-           (lambda _
-             (system "Xvfb &")
-             (setenv "DISPLAY" ":0")))
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (faad2 (assoc-ref inputs "faad2")))
-               (wrap-program (string-append out "/bin/mixxx")
-                 `("LD_LIBRARY_PATH" ":" prefix
-                   ,(list (string-append faad2 "/lib"))))))))))
-    (native-inputs
-     (list benchmark
-           googletest
-           python-wrapper
-           qttools-5
-           xorg-server-for-tests))
-    (inputs
-     (list bash-minimal
-           chromaprint
-           faad2
-           ffmpeg
-           fftw
-           flac
-           glu
-           hidapi
-           jack-1
-           lame
-           libdjinterop
-           libebur128
-           libid3tag
-           libkeyfinder
-           libmad
-           libmp4v2
-           libmodplug
-           libsndfile
-           libshout
-           ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
-           ;; lp1833225 and refuses to use it.  Use the bundle for now.
-           ;; libshout-idjc
-           libusb
-           libvorbis
-           lilv
-           mp3guessenc
-           openssl
-           opusfile
-           portaudio
-           portmidi
-           protobuf
-           qtbase-5
-           qtdeclarative-5
-           qtkeychain
-           qtscript
-           qtsvg-5
-           qtx11extras
-           rubberband
-           soundtouch
-           sqlite
-           taglib
-           upower
-           vamp
-           wavpack))
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'disable-bugged-test
+                    ;; This test regularly fails and aborts the build process, hence it
+                    ;; was disabled (no impact on functionality).  It appears this is a
+                    ;; problem for some upstream as well, as indicated by:
+                    ;; https://github.com/mixxxdj/mixxx/issues/12887 (featuring a
+                    ;; reference to another issue related to the same problem).
+                    (lambda _
+                      (substitute* "src/test/soundproxy_test.cpp"
+                        (("TEST_F\\(SoundSourceProxyTest, firstSoundTest\\)")
+                         "TEST_F(SoundSourceProxyTest, DISABLED_firstSoundTest)"))))
+                  (add-after 'install 'wrap-executable
+                    (lambda* (#:key inputs outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (faad2 (assoc-ref inputs "faad2")))
+                        (wrap-program (string-append out "/bin/mixxx")
+                          `("LD_LIBRARY_PATH" ":" prefix
+                            ,(list (string-append faad2 "/lib"))))))))))
+    (native-inputs (list benchmark googletest python-wrapper qttools-5
+                         xorg-server-for-tests))
+    (inputs (list bash-minimal
+                  chromaprint
+                  faad2
+                  ffmpeg
+                  fftw
+                  flac
+                  glu
+                  hidapi
+                  jack-1
+                  lame
+                  libdjinterop
+                  libebur128
+                  libid3tag
+                  libkeyfinder
+                  libmad
+                  libmp4v2
+                  libmodplug
+                  libsndfile
+                  libshout
+                  ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
+                  ;; lp1833225 and refuses to use it.  Use the bundle for now.
+                  libshout-idjc
+                  libusb
+                  libvorbis
+                  lilv
+                  mp3guessenc
+                  openssl
+                  opusfile
+                  portaudio
+                  portmidi
+                  protobuf
+                  qtbase-5
+                  qtdeclarative-5
+                  qtkeychain
+                  qtscript
+                  qtsvg-5
+                  qtx11extras
+                  rubberband
+                  soundtouch
+                  sqlite
+                  taglib
+                  upower
+                  vamp
+                  wavpack
+                  c++-gsl))
     (home-page "https://mixxx.org/")
     (synopsis "DJ software to perform live mixes")
     (description "Mixxx is a DJ software.  It integrates the tools DJs need to
diff --git a/gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch b/gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch
deleted file mode 100644
index d7cd1c0d28..0000000000
--- a/gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 7554aefc886d4ebc4b4c139a5cddcab6163cf72f Mon Sep 17 00:00:00 2001
-From: Vinicius Monego <monego@posteo.net>
-Date: Thu, 30 Sep 2021 23:37:29 -0300
-Subject: [PATCH] Link QtScriptByteArray with QtScript.
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 492ccae..05fec08 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -2077,7 +2077,7 @@ add_library(QtScriptByteArray STATIC EXCLUDE_FROM_ALL
-   lib/qtscript-bytearray/bytearrayprototype.cpp
- )
- set_target_properties(QtScriptByteArray PROPERTIES AUTOMOC ON)
--target_link_libraries(QtScriptByteArray Qt5::Core)
-+target_link_libraries(QtScriptByteArray Qt5::Core Qt5::Script)
- target_include_directories(mixxx-lib SYSTEM PUBLIC lib/qtscript-bytearray)
- target_link_libraries(mixxx-lib PRIVATE QtScriptByteArray)
- 
--- 
-2.30.2
-
diff --git a/gnu/packages/patches/mixxx-system-googletest-benchmark.patch b/gnu/packages/patches/mixxx-system-googletest-benchmark.patch
deleted file mode 100644
index 7adbe66208..0000000000
--- a/gnu/packages/patches/mixxx-system-googletest-benchmark.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From eb2079d467f8658eea13e2ed86cc69d864632866 Mon Sep 17 00:00:00 2001
-From: Vinicius Monego <monego@posteo.net>
-Date: Wed, 29 Sep 2021 19:07:35 -0300
-Subject: [PATCH] Use system googletest and benchmark.
-
----
- CMakeLists.txt | 13 +++----------
- 1 file changed, 3 insertions(+), 10 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 10e9b0a..492ccae 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1467,12 +1467,7 @@ set(gtest_force_shared_crt ON CACHE BOOL "Pass Mixxx compiler/linker options to
- # Prevent installation of GoogleTest libraries
- set(INSTALL_GTEST OFF CACHE BOOL "Disable installation of GoogleTest" FORCE)
- 
--# Add googletest directly to our build. This adds the following targets:
--# gtest, gtest_main, gmock and gmock_main
--add_subdirectory(
--  "${CMAKE_CURRENT_SOURCE_DIR}/lib/googletest"
--  "${CMAKE_CURRENT_BINARY_DIR}/lib/googletest"
--)
-+find_package(GTest CONFIG REQUIRED)
- 
- add_executable(mixxx-test
-   src/test/analyserwaveformtest.cpp
-@@ -1582,10 +1577,8 @@ set(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE)
- # Prevent installation of google/benchmark artifacts
- set(BENCHMARK_ENABLE_INSTALL OFF CACHE BOOL "Disable installation of google/benchmark" FORCE)
- 
--add_subdirectory(
--  "${CMAKE_CURRENT_SOURCE_DIR}/lib/benchmark"
--  "${CMAKE_CURRENT_BINARY_DIR}/lib/benchmark"
--)
-+find_package(benchmark CONFIG REQUIRED)
-+
- target_link_libraries(mixxx-test PRIVATE benchmark)
- 
- # Test Suite
--- 
-2.30.2
-