summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-05-20 21:46:03 -0300
committerVinicius Monego <monego@posteo.net>2023-09-16 23:10:52 -0300
commitc7bd5811da38509762609eb8dcae90ed9b610421 (patch)
tree940fa018c1d388a89efc484151f3f134f92fdb95
parent70b8682eaa94b5a6517a8fe733eb599ca2a778e3 (diff)
downloadguix-c7bd5811da38509762609eb8dcae90ed9b610421.tar.gz
gnu: Add python-linear-operator.
* gnu/packages/machine-learning.scm (python-linear-operator): New variable.
-rw-r--r--gnu/packages/machine-learning.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 92a60d1616..717c52345c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4571,6 +4571,32 @@ and Numpy.")
 inference.")
     (license license:asl2.0)))
 
+(define-public python-linear-operator
+  (package
+    (name "python-linear-operator")
+    (version "0.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "linear_operator" version))
+              (sha256
+               (base32
+                "03drb4hn9nn8jrqd9vbalihhahgpdm956hbs05bix7svradhknaw"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-jaxtyping
+                             python-pytorch
+                             python-scipy
+                             python-typeguard))
+    (native-inputs (list python-flake8
+                         python-flake8-print
+                         python-pytest
+                         python-setuptools-scm
+                         python-twine))
+    (home-page "https://github.com/cornellius-gp/linear_operator/")
+    (synopsis "Linear operator implementation")
+    (description "LinearOperator is a PyTorch package for abstracting away the
+linear algebra routines needed for structured matrices (or operators).")
+    (license license:expat)))
+
 (define-public vosk-api
   (let* ((openfst openfst-for-vosk)
          (kaldi kaldi-for-vosk))