summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-01 00:24:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-01 01:19:22 -0400
commitc7c500dd61ec4bf6feb9769858b3a7041c9ace71 (patch)
treefd11059ea16ec756ac7afe9dc5e126176484bae2
parentf66fa5f917e76935187935b09ae7ac037b8b35f8 (diff)
downloadguix-c7c500dd61ec4bf6feb9769858b3a7041c9ace71.tar.gz
gnu: patman: Fix execution.
Before this change, patman would fail at run time with "AttributeError: module
'patman.__main__' has no attribute 'run_patman'" since the last U-Boot update.

* gnu/packages/bootloaders.scm (patman) [arguments]
<phases>: New patch-pyproject.toml phase.
-rw-r--r--gnu/packages/bootloaders.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 069d02b52c..1c47636341 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -881,7 +881,17 @@ commands part of the U-Boot project, such as Patman.")))
           (delete 'sanity-check)
           (add-after 'unpack 'chdir
             (lambda _
-              (chdir "tools/patman"))))))
+              (chdir "tools/patman")))
+          (add-after 'chdir 'patch-pyproject.toml
+            ;; There is no 'run_patman' procedure in the __main__.py script,
+            ;; which breaks execution
+            ;; Patch submitted upstream (see:
+            ;; https://patchwork.ozlabs.org/project/uboot/\
+            ;; patch/20230901050532.725-1-maxim.cournoyer@gmail.com/).
+            (lambda _
+              (substitute* "pyproject.toml"
+                (("patman.__main__:run_patman")
+                 "patman.__main__")))))))
     (inputs (list python-pygit2 python-requests python-u-boot-pylib))
     (synopsis "Patch automation tool")
     (description "Patman is a patch automation script which: