summary refs log tree commit diff
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2024-06-03 14:47:35 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-06-28 11:41:50 +0200
commitcb6e721ea1afc9dccab435a5a95f0e053508b57f (patch)
tree2f135d08eee153c66e29ef2baaad42829d54241d
parent78b881722f08325c76096557313a0faee847c66f (diff)
downloadguix-cb6e721ea1afc9dccab435a5a95f0e053508b57f.tar.gz
gnu: Add r-topdom.
* gnu/packages/cran.scm (r-topdom): New variable.

Change-Id: I63d265470499affc8f0de94f88739c6631281a0d
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 85e0fa98f9..9e3f4648bc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31108,6 +31108,30 @@ and multivariate regression), and analysis of variance tolerance intervals.
 Visualizations are also available for most of these settings.")
     (license license:gpl2+)))
 
+(define-public r-topdom
+  (package
+    (name "r-topdom")
+    (version "0.10.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "TopDom" version))
+       (sha256
+        (base32 "1rryfnwvdlpdrjgs6sciy91cxfp4jykll0swclasydjvj4n642i6"))))
+    (properties `((upstream-name . "TopDom")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ggplot2 r-matrixstats r-reshape2 r-tibble))
+    (home-page "https://github.com/HenrikBengtsson/TopDom")
+    (synopsis "Efficient method for identifying genomic topological domains")
+    (description
+     "This method identifies topological domains in genomes from Hi-C sequence
+data.  The authors published an implementation of their method as an R script.
+This package originates from those original @code{TopDom} R scripts and
+provides help pages adopted from the original @code{TopDom} PDF documentation.
+It also provides a small number of bug fixes to the original code.")
+    ;; Either version of the GPL
+    (license (list license:gpl2 license:gpl3))))
+
 ;; Keep this in sync with the liblantern package.
 (define-public r-torch
   (package