summary refs log tree commit diff
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-22 13:21:22 +0300
committerAndrew Tropin <andrew@trop.in>2024-09-05 09:29:52 +0400
commitcb7de07a51f22e3c91eef5c57f47356ebf1500a3 (patch)
tree573b7b07e5f2c255bd68e1c18522072dcc301a73
parent20b1613484f512649f919d89285e981998592497 (diff)
downloadguix-cb7de07a51f22e3c91eef5c57f47356ebf1500a3.tar.gz
gnu: ejabberd: Add inputs and wrap-program phase.
* gnu/packages/messaging.scm (ejabberd): Add inputs and wrap-program phase.

Change-Id: Id8177c54437dca9b98bbd6a237b9a713bc904c84
Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/messaging.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 6355c73fe6..c482cd469e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3659,6 +3659,7 @@ a text snippet), using @code{libphonenumber}.")
        (sha256
         (base32 "0d5i9skgfjzs2100k0g99sigc2w61480ysz3va6pmb4nx43100g3"))))
     (build-system rebar-build-system)
+    (inputs (list bash-minimal coreutils procps sed))
     (native-inputs
      (list autoconf
            automake
@@ -3771,7 +3772,18 @@ a text snippet), using @code{libphonenumber}.")
                                 (string-append erts "/bin")))
                 (chmod (string-append ejabberd
                                       "/bin/install_upgrade.escript") #o755)
-                (copy-recursively ejabberd #$output)))))))
+                (copy-recursively ejabberd #$output))))
+          (add-after 'install 'wrap-program
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out")))
+                (wrap-program (string-append out "/bin/ejabberdctl")
+                  `("PATH" ":" suffix
+                    ,(map (lambda (command)
+                            (dirname
+                             (search-input-file
+                              inputs (string-append "bin/" command))))
+                          (list "date" "dirname" "grep"
+                                "id" "pgrep" "sed"))))))))))
     (synopsis "Robust, Ubiquitous and Massively Scalable Messaging Platform")
     (description "This package provides Ejabberd -- Robust, Ubiquitous and
 Massively Scalable Messaging Platform.  It supports XMPP, MQTT and SIP