summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-01-28 23:02:01 +0000
committerChristopher Baines <mail@cbaines.net>2024-02-13 11:04:48 +0000
commitcc772e7f3172a8014e32c7ea3f6626963d4e9e16 (patch)
tree3d6e6c7ac905b43b70f52a8b39eb9ed43c6eab06
parent52cca41c6fdb35d25c0543fef5fd90ebc855163c (diff)
downloadguix-cc772e7f3172a8014e32c7ea3f6626963d4e9e16.tar.gz
gnu: freesasa: Fix memerr tests.
* gnu/packages/chemistry.scm (freesasa)[arguments]: Add
"CFLAGS=-fno-builtin-malloc" to #:configure-flags.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/chemistry.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 5e19bdf182..98141737ac 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -708,7 +708,12 @@ It can be used for working with
       #~(list "--enable-check"
               "--enable-parser-generator"
               "CXXFLAGS=-std=c++17"
-              "--enable-doxygen")
+              "--enable-doxygen"
+              ;; Some tests rely on replacing malloc with a wrapper which
+              ;; fails in a controlled way, but this does not work if the call
+              ;; is replaced. This was fixed upstream, remove once there is a
+              ;; new release.
+              "CFLAGS=-fno-builtin-malloc")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'remove-libc++-linking