summary refs log tree commit diff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-03-02 22:46:33 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:55 +0200
commitce170fb4ca85086a9ae5ec8135d8ad3e2c5d51a5 (patch)
treedda94a3e3e1750c0472c1be79d662901c660fb83
parent550640a5b7aea4764d1ea179df98da6862d52e3e (diff)
downloadguix-ce170fb4ca85086a9ae5ec8135d8ad3e2c5d51a5.tar.gz
gnu: guile-1.8: Add libxcrypt dependency.
* gnu/packages/guile.scm (guile-1.8): Add libxcrypt dependency, and include it
in the pkg-config file's flags.

Change-Id: I050e8d2bee0b6195a6a854338d39a9594b0088b9
-rw-r--r--gnu/packages/guile.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index dfa26e24ca..89b9869550 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -42,6 +42,7 @@
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages crypto)
   #:use-module (gnu packages dbm)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gawk)
@@ -109,7 +110,19 @@
 
                       ;; The usual /bin/sh...
                       (substitute* "ice-9/popen.scm"
-                        (("/bin/sh") (which "sh"))))))
+                        (("/bin/sh") (which "sh")))))
+                  (add-after 'install 'add-libxcrypt-reference-pkgconfig
+                    (lambda* (#:key inputs outputs #:allow-other-keys)
+                      (define out (assoc-ref outputs "out"))
+                      (define libxcrypt
+                        (false-if-exception
+                         (dirname (search-input-file inputs "lib/libcrypt.so.1"))))
+                      (when libxcrypt
+                        (substitute*
+                            (find-files (string-append out "/lib/pkgconfig")
+                                        ".*\\.pc")
+                          (("-lcrypt")
+                           (string-append "-L" libxcrypt " -lcrypt")))))))
 
                 ;; XXX: Several numerical tests and tests related to
                 ;; 'inet-pton' fail on glibc 2.33/GCC 10.  Disable them.
@@ -122,7 +135,7 @@
                       `(("self" ,this-package))
                       '()))
 
-   (inputs (list gawk readline))
+   (inputs (list gawk libxcrypt readline))
 
    ;; Since `guile-1.8.pc' has "Libs: ... -lgmp -lltdl", these must be
    ;; propagated.