summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-22 14:06:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-22 14:10:57 +0100
commitce320d27d82fa3ece26336a6f4332f28c46e0293 (patch)
treef2108916a14bcd97188ed1fbfec740e730a7115b
parentf6f3d8a76e52394ac562fd314090d9bbbef59636 (diff)
downloadguix-ce320d27d82fa3ece26336a6f4332f28c46e0293.tar.gz
gnu: python-sqlalchemy-2: Improve package style.
Add missing input as seen python-team build
<https://ci.guix.gnu.org/build/6245544/log/raw>.

* gnu/packages/databases.scm (python-sqlalchemy-2): Improve packge
style. Shift order of the fields.
[arguments]<#:phases>: Remove all custom phases, swap tests deletion
and substitution with "--ignore" and "-k" options in <#:test-flags>.
[propagated-inputs]: Add python-greenlet.
[native-inputs]: Add python-cython and python-setuptools.
[description]: Fix indentation.

Change-Id: Ib1f145efe8d9b24aa069a4c616525855b278568b
-rw-r--r--gnu/packages/databases.scm48
1 files changed, 19 insertions, 29 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c3f7011f79..663ff8fd26 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3674,40 +3674,30 @@ simple and Pythonic domain language.")
        (sha256
         (base32 "1i99kgm8hc38iffgp3wdbixpdc5jfjklabh8lyp9h8vd1dl6f9vz"))))
     (build-system pyproject-build-system)
-    (native-inputs (list python-pytest))
-    (propagated-inputs (list python-typing-extensions))
     (arguments
      (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-after 'unpack 'disable-tests
-            (lambda _
-              ;; Remove expensive tests.
-              (for-each delete-file
-                        '("test/ext/mypy/test_mypy_plugin_py3k.py"
-                          "test/typing/test_mypy.py"
-                          "test/aaa_profiling/test_memusage.py"))
-              (substitute* "test/engine/test_pool.py"
-                ;; Disable a test that fails randomly.
-                (("def test_recycle_pool_no_race")
-                 "def _test_recycle_pool_no_race"))))
-          ;; According to the pyproject.toml, greenlet is optional.
-          (add-after 'unpack 'remove-dependency-on-greenlet
-            (lambda _
-              (substitute* "setup.cfg"
-                (("greenlet != 0.4.17")
-                 "#greenlet != 0.4.17"))
-              (substitute* "PKG-INFO"
-                (("Requires-Dist: greenlet")
-                 "#Requires-Dist: greenlet")))))))
+      #:test-flags
+      ;; Remove expensive tests.
+      #~(list "--ignore=test/aaa_profiling/test_memusage.py"
+              "--ignore=test/ext/mypy/test_mypy_plugin_py3k.py"
+              "--ignore=test/typing/test_mypy.py"
+              ;; Disable a test that fails randomly.
+              "-k" "test_recycle_pool_no_race")))
+    (native-inputs
+     (list python-cython
+           python-pytest
+           python-setuptools))
+    (propagated-inputs
+     (list python-greenlet
+           python-typing-extensions))
     (home-page "https://www.sqlalchemy.org")
     (synopsis "SQL toolkit and object relational mapper")
     (description
-     "SQLAlchemy is the Python SQL toolkit and @acronym{ORM, Object Relational Mapper}
-that gives application developers the full power and flexibility of SQL.  It provides
-a full suite of well known enterprise-level persistence patterns, designed for
-efficient and high-performing database access, adapted into a simple and Pythonic
-domain language.")
+     "SQLAlchemy is the Python SQL toolkit and @acronym{ORM, Object Relational
+Mapper} that gives application developers the full power and flexibility of
+SQL.  It provides a full suite of well known enterprise-level persistence
+patterns, designed for efficient and high-performing database access, adapted
+into a simple and Pythonic domain language.")
     (license license:expat)))
 
 (define-public python-sqlalchemy-stubs