summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 13:19:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:19 +0200
commitcf1517a1b76b37c96eb4892ecfb6f2fabf0fde49 (patch)
treed2ada0a1507faf057d2e5f2c42a8dbac792c0450
parent7c4f9c17dee9aa62f9ad050c829c0b79b1e36cec (diff)
downloadguix-cf1517a1b76b37c96eb4892ecfb6f2fabf0fde49.tar.gz
gnu: python-ipywidgets: Update to 7.6.3.
* gnu/packages/python-xyz.scm (python-ipywidgets): Update to 7.6.3.
[propagated-inputs]: Add python-ipython, python-jupyterlab-widgets, and
python-nbformat.
[native-inputs]: Remove python-nose; add python-mock and ptyhon-pytest-cov.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e3aa20dc5d..9660f6ffd2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10545,22 +10545,26 @@ notebooks.")
 (define-public python-ipywidgets
   (package
     (name "python-ipywidgets")
-    (version "7.5.1")
+    (version "7.6.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "ipywidgets" version))
        (sha256
         (base32
-         "15sww2mvnkqlvx55gwa82v05062a8j1xpncnqna4k9sl53hgcig9"))))
+         "1w217j8i53x14l7b05fk300k222zs9vkcjaa1rbrw3sk43k466lz"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-ipython" ,python-ipython)
+     `(("python-ipykernel" ,python-ipykernel)
+       ("python-ipython" ,python-ipython)
+       ("python-jupyterlab-widgets" ,python-jupyterlab-widgets)
+       ("python-nbformat" ,python-nbformat)
        ("python-traitlets" ,python-traitlets)
        ("python-widgetsnbextension" ,python-widgetsnbextension)))
     (native-inputs
-     `(("python-nose" ,python-nose)
-       ("python-pytest" ,python-pytest)))
+     `(("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)))
     (home-page "https://ipython.org")
     (synopsis "IPython HTML widgets for Jupyter")
     (description "Ipywidgets are interactive HTML widgets for Jupyter