summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 12:19:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:54 +0200
commitd0d99aa75cd7e2959b38d2c5220c672eee8f8f09 (patch)
tree81295e6216979add8fe60d017f529730cfeab8e7
parent0d8da17c29249eec535fd6ea311e22202229ddd7 (diff)
downloadguix-d0d99aa75cd7e2959b38d2c5220c672eee8f8f09.tar.gz
gnu: julia-plotutils: Update to 1.2.0.
* gnu/packages/julia-xyz.scm (julia-plotutils): Update to 1.2.0.
[arguments]: Add a phase to adjust the test suite.
-rw-r--r--gnu/packages/julia-xyz.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 2f29df20b8..d838c4677d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4326,7 +4326,7 @@ actual computation.")
 (define-public julia-plotutils
   (package
     (name "julia-plotutils")
-    (version "1.0.15")
+    (version "1.2.0")
     (source
       (origin
         (method git-fetch)
@@ -4335,8 +4335,17 @@ actual computation.")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "12aw5gkkcfhpczv2w510k65w1j0hjnh825ihimi223v8plsi5105"))))
+         (base32 "1yml9ayaniqnzx5r8sfjckifcm99ck7qhc19cd8fs0bwzkh7nza7"))))
     (build-system julia-build-system)
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-after 'unpack 'adjust-test-suite
+             (lambda _
+               (substitute* "test/runtests.jl"
+                 (("(@test_throws) ErrorException (.*notacolor)" _ @test notacolor)
+                  (string-append @test " ArgumentError " notacolor))))))))
     (propagated-inputs
      (list julia-colors
            julia-colorschemes