summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-07 21:54:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:22 +0100
commitd36c8fb18cf0787c8b200f31a67894def20ad10b (patch)
tree84ea9d1d6b9b945ecab21f0a7e486659b5b7ae0d
parent6bfa7ccb23c9baab73d6aa54029515af4dd24021 (diff)
downloadguix-d36c8fb18cf0787c8b200f31a67894def20ad10b.tar.gz
gnu: Add go-github-com-remeh-sizedwaitgroup.
* gnu/packages/golang-xyz.scm (go-github-com-remeh-sizedwaitgroup): New variable.

Change-Id: Icabe407a0aefef2728e331be87e239b7683512cd
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0208063845..e7fabd6b94 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3663,6 +3663,33 @@ Metrics library.")
       (home-page "https://github.com/rcrowley/go-metrics")
       (license license:bsd-2))))
 
+(define-public go-github-com-remeh-sizedwaitgroup
+  (package
+    (name "go-github-com-remeh-sizedwaitgroup")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/remeh/sizedwaitgroup")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xwdzby27xzcghsqhli3il165iz3vkx3g4abgvkl99wysyhcvn0a"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/remeh/sizedwaitgroup"))
+    (home-page "https://github.com/remeh/sizedwaitgroup")
+    (synopsis "Goroutines limit amount implementation of standard @code{sync.WaitGroup}")
+    (description
+     "This package implements a feature of limiting the maximum number of
+concurrently started routines which has the same role and API as
+@code{sync.WaitGroup}.  It could for example be used to start multiples
+routines querying a database but without sending too much queries in order to
+not overload the given database.")
+    (license license:expat)))
+
 (define-public go-github-com-schollz-progressbar-v3
   (package
     (name "go-github-com-schollz-progressbar-v3")