summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-10-11 22:08:14 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-10-11 22:08:14 -0400
commitd6d706a58b8159748d3a46fa97cae18850487c8a (patch)
tree86f890d98ca854689922d05e7fc5e7db92a1eef5
parent2610166c37d19dbd00dbb860b1ac2de45f415b4d (diff)
downloadguix-d6d706a58b8159748d3a46fa97cae18850487c8a.tar.gz
gnu: curl/fixed: Update to 8.4.0 [security fixes].
Fixes CVE-2023-38545 and CVE-2023-38546.  See
<https://curl.se/docs/CVE-2023-38545.html> and
<https://curl.se/docs/CVE-2023-38546.html> for details.

* gnu/packages/curl.scm (curl/fixed): Update to 8.4.0.
-rw-r--r--gnu/packages/curl.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index e3d17f97b7..e3234292eb 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -156,7 +156,7 @@ tunneling, and so on.")
     (home-page "https://curl.haxx.se/")))
 
 (define curl/fixed
-  (let ((%version "8.3.0"))
+  (let ((%version "8.4.0"))
     (package
       (inherit curl)
       (version "8.3.0a")               ; add lowercase 'a' for grafting
@@ -166,7 +166,7 @@ tunneling, and so on.")
                                     %version ".tar.xz"))
                 (sha256
                  (base32
-                  "0qza6yf20y2l4aaxkn8dfw8p3fls1mxljvdb0m8z1i6ncxvn4v9p"))
+                  "0bd8y8v66biyqvg70ka1sdd0aixs6yzpnvfsig907xzh9af2mihn"))
                 (patches (search-patches "curl-use-ssl-cert-env.patch"))))
       (arguments
        (if (system-hurd?)