summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-08-13 19:45:00 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-08-13 21:21:30 +0200
commitd75210a871b13b3fc5a3c2a5e065baff9b84638d (patch)
tree7a2901e8e004e5f9ad25fa209cec3dbc3d9e334f
parent96b3449823089ad86db7ca9d026b9d00645ae5fa (diff)
downloadguix-d75210a871b13b3fc5a3c2a5e065baff9b84638d.tar.gz
gnu: ocaml-odoc-parser: Update to 2.0.0.
* gnu/packages/ocaml.scm (ocaml-odoc-parser): Update to 2.0.0.
(ocamlformat): Update to 0.24.1.
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 75a8c25bfa..a4c76ea5e1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7698,7 +7698,7 @@ complexity of the OCaml module system.")
 (define-public ocaml-odoc-parser
   (package
     (name "ocaml-odoc-parser")
-    (version "1.0.0")
+    (version "2.0.0")
     (source
       (origin
         (method git-fetch)
@@ -7708,10 +7708,10 @@ complexity of the OCaml module system.")
         (file-name (git-file-name name version))
         (sha256
           (base32
-           "0mvwbnla0wd29bc7ckwpb494qv7p616cx8hnm0zg36np7v3zwy4w"))))
+           "1x48kf051xs98rd6cri591bk1ccp9hyp93n1rlf6qnxic55jw683"))))
     (build-system dune-build-system)
     (propagated-inputs
-      (list ocaml-astring ocaml-result))
+      (list ocaml-astring ocaml-camlp-streams ocaml-result))
     (native-inputs
       (list ocaml-ppx-expect))
     (home-page "https://github.com/ocaml-doc/odoc-parser")
@@ -8227,7 +8227,7 @@ defined in OCaml 4.12.0.")
 (define-public ocamlformat
   (package
     (name "ocamlformat")
-    (version "0.22.4")
+    (version "0.24.1")
     (source
       (origin
         (method git-fetch)
@@ -8237,7 +8237,7 @@ defined in OCaml 4.12.0.")
         (file-name (git-file-name name version))
         (sha256
           (base32
-            "171lq3vx4y8xj4by5zy93isx8nhg6ysxg1hxmkqkq16fdaiz8mnc"))))
+            "0y1j5mwwrliy6a78cmpi6j8gw425shghqg9ylyl3qw5fx4b088pp"))))
     (build-system dune-build-system)
     (arguments
      '(#:package "ocamlformat"