summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-03 01:36:35 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-03 13:54:13 +0100
commitd774fabe4b44ec652c0209f3cb474a7c94f52e07 (patch)
tree31d24acee4d3aba8b23936845681595f8fa051ef
parent07cb1dfc57a2ce95b41b4bef894bed413c4fb6ec (diff)
downloadguix-d774fabe4b44ec652c0209f3cb474a7c94f52e07.tar.gz
gnu: hexchat: Update to 2.14.3.
* gnu/packages/messaging.scm (hexchat): Update to 2.14.3.
[source]: Remove patch.
* gnu/packages/patches/hexchat-crash-exit.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/messaging.scm7
-rw-r--r--gnu/packages/patches/hexchat-crash-exit.patch31
3 files changed, 3 insertions, 36 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8a21223de5..c7dcc65082 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -997,7 +997,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/hdf-eos5-remove-gctp.patch		\
   %D%/packages/patches/hdf-eos5-fix-szip.patch			\
   %D%/packages/patches/hdf-eos5-fortrantests.patch		\
-  %D%/packages/patches/hexchat-crash-exit.patch			\
   %D%/packages/patches/higan-remove-march-native-flag.patch	\
   %D%/packages/patches/hubbub-sort-entities.patch		\
   %D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch        \
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3202bd2f44..6917d23f84 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -10,7 +10,7 @@
 ;;; Copyright © 2016, 2017, 2018, 2019 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
 ;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
@@ -263,15 +263,14 @@ access to servers running the Discord protocol.")
 (define-public hexchat
   (package
     (name "hexchat")
-    (version "2.14.2")
+    (version "2.14.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "064nq151nzsljv97dmkifyl162d2738vbgvm1phx7yv04pjvk4kp"))
-              (patches (search-patches "hexchat-crash-exit.patch"))))
+                "10p829jm1r6kidkgf5lhqhyqc5mxdcq96q3zhadsckasvc9rs6lh"))))
     (build-system meson-build-system)
     (native-inputs `(("gettext" ,gettext-minimal)
                      ("glib:bin" ,glib "bin")       ;need glib-genmarshal
diff --git a/gnu/packages/patches/hexchat-crash-exit.patch b/gnu/packages/patches/hexchat-crash-exit.patch
deleted file mode 100644
index e67fef73e0..0000000000
--- a/gnu/packages/patches/hexchat-crash-exit.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From d9c637ae8a1137d3ca512d2c560589903a4bd79d Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Tue, 30 Apr 2019 11:16:01 -0700
-Subject: [PATCH] Python plugin: Call EndInterpreter when deinit'ing the plugin
-
-This fixes https://github.com/hexchat/hexchat/issues/2237 , a
-commonly-encountered bug when using Hexchat 2.14 on Python 3.7.
-Thanks to @ncoghlan for the fix.
-
-Signed-off-by: Adam Williamson <awilliam@redhat.com>
----
- plugins/python/python.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/plugins/python/python.c b/plugins/python/python.c
-index 4403474d..475756ba 100644
---- a/plugins/python/python.c
-+++ b/plugins/python/python.c
-@@ -2806,6 +2806,9 @@ hexchat_plugin_deinit(void)
- 	xchatout_buffer = NULL;
- 
- 	if (interp_plugin) {
-+		PyThreadState *tstate = ((PluginObject*)interp_plugin)->tstate;
-+		PyThreadState_Swap(tstate);
-+		Py_EndInterpreter(tstate);
- 		Py_DECREF(interp_plugin);
- 		interp_plugin = NULL;
- 	}
--- 
-2.21.0
-