summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 11:34:41 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:56 +0000
commitd8717abb49f9e7dbb2cd473e441b109712dc2478 (patch)
tree91e85c9efacb7e5e10a03e36fe50ae9bd0a923e2
parenteb23cceba53a491272372a7ec4a077b603520905 (diff)
downloadguix-d8717abb49f9e7dbb2cd473e441b109712dc2478.tar.gz
gnu: go-github-com-subosito-gotenv: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-subosito-gotenv): Move from
here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: Ic9733d34808da599536a34b33caad88707f8ebb7
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0aeabccefa..177ab8a20f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6932,6 +6932,33 @@ well as a program to generate applications and command files.")
 slices, JSON and other data.")
     (license license:expat)))
 
+(define-public go-github-com-subosito-gotenv
+  (package
+    (name "go-github-com-subosito-gotenv")
+    (version "1.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/subosito/gotenv")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0h7kb9mc67rl16kvls2d16pimdrz59l5x4l002qsv2p2766mpjif"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/subosito/gotenv"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (propagated-inputs
+     (list go-golang-org-x-text))
+    (home-page "https://github.com/subosito/gotenv")
+    (synopsis "Go library for loading environment variables from files")
+    (description
+     "Go library for loading environment variables from files")
+    (license license:expat)))
+
 (define-public go-github-com-syndtr-goleveldb
   (package
     (name "go-github-com-syndtr-goleveldb")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index acd125e9b9..5ac739ddd8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3375,32 +3375,6 @@ updating files, like @command{tail -f}.")
     (description "Java properties scanner for Go")
     (license license:bsd-2)))
 
-(define-public go-github-com-subosito-gotenv
-  (package
-    (name "go-github-com-subosito-gotenv")
-    (version "1.6.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/subosito/gotenv")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0h7kb9mc67rl16kvls2d16pimdrz59l5x4l002qsv2p2766mpjif"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/subosito/gotenv"))
-    (native-inputs
-     (list go-github-com-stretchr-testify))
-    (propagated-inputs
-     (list go-golang-org-x-text))
-    (home-page "https://github.com/subosito/gotenv")
-    (synopsis "Go library for loading environment variables from files")
-    (description "Go library for loading environment variables from files")
-    (license license:expat)))
-
 (define-public go-github-com-sirupsen-logrus
   (package
     (name "go-github-com-sirupsen-logrus")