summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-15 09:26:38 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:45 +0200
commitda1d28755ebc3bf9b97a3950f447b3de9a62c3da (patch)
treedbeabadacb668f7a35c47c105376c86674ed0c8f
parent5952f575df1b0900f3b5c9ed6fa3fb8ef2e7a6dd (diff)
downloadguix-da1d28755ebc3bf9b97a3950f447b3de9a62c3da.tar.gz
gnu: Add rust-fxhash-0.2.
* gnu/packages/crates-io.scm (rust-fxhash-0.2): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 149141bd61..15dba2fde7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3027,6 +3027,34 @@ futures-rs library.")
 library.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-fxhash-0.2
+  (package
+    (name "rust-fxhash")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fxhash" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "037mb9ichariqi45xm6mz0b11pa92gj38ba0409z3iz239sns6y3"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-byteorder" ,rust-byteorder-1.3))
+       #:cargo-development-inputs
+       (("rust-fnv" ,rust-fnv-1.0)
+        ("rust-seahash" ,rust-seahash-3.0))))
+    (home-page "https://github.com/cbreeden/fxhash")
+    (synopsis "Hashing algorithm from hasher used in FireFox and Rustc")
+    (description
+     "This package provides a fast, non-secure, hashing algorithm
+derived from an internal hasher used in FireFox and Rustc.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-gcc-0.3
   (package
     (inherit rust-cc-1.0)