summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:36:51 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-21 23:50:26 +0000
commitda53479a3cb851e03be48bd6109cd68ac5d948e9 (patch)
treea93bc22dc2b43b78c64517584150ddf5396f9186
parentabedc7444e15b99d9f0553de7051fe15398ff2d6 (diff)
downloadguix-da53479a3cb851e03be48bd6109cd68ac5d948e9.tar.gz
gnu: go-github-com-quic-go-qpack: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-quic-go-qpack): Move from here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: I63b3feb07b330d164c91adaf32077f01fd705484
-rw-r--r--gnu/packages/golang-web.scm34
-rw-r--r--gnu/packages/golang.scm33
2 files changed, 34 insertions, 33 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 99210d8448..8bda7d60c6 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1450,6 +1450,40 @@ Caching.")
 to jQuery to the Go language.")
     (license license:bsd-3)))
 
+(define-public go-github-com-quic-go-qpack
+  (package
+    (name "go-github-com-quic-go-qpack")
+    (version "0.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/quic-go/qpack")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00mjz445hhx4yar5l8p21bpp4d06jyg2ajw0ax7bh64d37l4kx39"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      ;; Tests require ginkgo v2.
+      #:tests? #f
+      #:go go-1.20
+      #:import-path "github.com/quic-go/qpack"))
+    (propagated-inputs
+     (list go-github-com-onsi-ginkgo
+           go-github-com-onsi-gomega
+           go-golang-org-x-net))
+    (home-page "https://github.com/quic-go/qpack")
+    (synopsis "Minimal QPACK (RFC 9204) implementation for Go")
+    (description
+     "A minimal QPACK (RFC 9204) implementation in Go.  It is minimal in the sense
+that it doesn't use the dynamic table at all, but just the static table and (Huffman
+encoded) string literals.  Wherever possible, it reuses code from the
+@url{https://github.com/golang/net/tree/master/http2/hpack, HPACK implementation in
+the Go standard library}.")
+    (license license:expat)))
+
 (define-public go-github-com-sourcegraph-jsonrpc2
   (package
     (name "go-github-com-sourcegraph-jsonrpc2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6a244152d5..f2084dfc4b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5971,39 +5971,6 @@ implementation of generics.")
     (home-page "https://github.com/cheekybits/genny/")
     (license license:expat)))
 
-(define-public go-github-com-quic-go-qpack
-  (package
-    (name "go-github-com-quic-go-qpack")
-    (version "0.4.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/quic-go/qpack")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "00mjz445hhx4yar5l8p21bpp4d06jyg2ajw0ax7bh64d37l4kx39"))))
-    (build-system go-build-system)
-    (arguments
-     (list
-      #:import-path "github.com/quic-go/qpack"
-      ;; Tests require ginkgo v2.
-      #:tests? #f
-      #:go go-1.20))
-    (propagated-inputs (list go-github-com-onsi-gomega
-                             go-github-com-onsi-ginkgo
-                             go-golang-org-x-net))
-    (synopsis "Minimal QPACK (RFC 9204) implementation for Go")
-    (description
-     "A minimal QPACK (RFC 9204) implementation in Go.  It is minimal in the sense
-that it doesn't use the dynamic table at all, but just the static table and (Huffman
-encoded) string literals.  Wherever possible, it reuses code from the
-@url{https://github.com/golang/net/tree/master/http2/hpack, HPACK implementation in
-the Go standard library}.")
-    (home-page "https://github.com/quic-go/qpack")
-    (license license:expat)))
-
 (define-public go-github-com-quic-go-quic-go
   (package
     (name "go-github-com-quic-go-quic-go")