summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-31 13:44:10 +0000
committerChristopher Baines <mail@cbaines.net>2018-02-01 20:21:25 +0000
commitda6f9d41c15f6d9f265d60ef01293f3431651c85 (patch)
treebc49c31ec45a0bcc6688ada1d94f5f1948508387
parent7952804cecf670b4b0d6f75df6f86d64c5b65e71 (diff)
downloadguix-da6f9d41c15f6d9f265d60ef01293f3431651c85.tar.gz
gnu: Add go-github.com-jtolds-gls.
* gnu/packages/golang.scm (go-github.com-jtolds-gls): New variable.
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b8eb90ed9e..3149d36bae 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -496,3 +496,26 @@ way of specifying command line options.")
 termination.")
       (home-page "https://gopkg.in/tomb.v2")
       (license license:bsd-3))))
+
+(define-public go-github.com-jtolds-gls
+  (package
+    (name "go-github.com-jtolds-gls")
+    (version "4.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jtolds/gls")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vm37pvn0k4r6d3m620swwgama63laz8hhj3pyisdhxwam4m2g1h"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/jtolds/gls"))
+    (synopsis "@code{gls} provides Goroutine local storage")
+    (description
+     "The @code{gls} package provides a way to store a retrieve values
+per-goroutine.")
+    (home-page "https://github.com/jtolds/gls")
+    (license license:expat)))