summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 10:22:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:41 +0100
commitdcfdd70d538d9bb7f82ce2ea1a93d8206d54a4b6 (patch)
tree339ef1c5bab6685507f4c7fcaadb0f53ae6de7cf
parent0540c0ccb275c2a01bf7d9084a65a775d7863ae0 (diff)
downloadguix-dcfdd70d538d9bb7f82ce2ea1a93d8206d54a4b6.tar.gz
gnu: go-golang-org-x-crypto: Update to 0.14.0.
* gnu/packages/golang-build.scm (go-golang-org-x-crypto): Update to 0.14.0.
[propagated-inputs]: Add go-golang-org-x-net, go-golang-org-x-term and
go-golang-org-x-text.

Change-Id: I0b064137070be75545f012fc7a89280522855e27
-rw-r--r--gnu/packages/golang-build.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 9bc9802d19..086dbaeb17 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -79,7 +79,7 @@
 (define-public go-golang-org-x-crypto
   (package
     (name "go-golang-org-x-crypto")
-    (version "0.4.0")
+    (version "0.14.0")
     (source
      (origin
        (method git-fetch)
@@ -89,7 +89,7 @@
        (file-name (string-append "go.googlesource.com-crypto-"
                                  version "-checkout"))
        (sha256
-        (base32 "13i0yz4hvc4qdr438nmzilvl5ns73v3910bakcddny3jbzq72i2m"))))
+        (base32 "08124qkp0l0blq6rw68llfbf84kp99255q0yvxyv27c05b0wkh66"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "golang.org/x/crypto"
@@ -100,7 +100,10 @@
          ;; Source-only package
          (delete 'build))))
     (propagated-inputs
-     (list go-golang-org-x-sys))
+     (list go-golang-org-x-net
+           go-golang-org-x-sys
+           go-golang-org-x-term
+           go-golang-org-x-text))
     (home-page "https://go.googlesource.com/crypto/")
     (synopsis "Supplementary cryptographic libraries in Go")
     (description "This package provides supplementary cryptographic libraries