summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-04-10 09:15:13 +0200
committerLudovic Courtès <ludo@gnu.org>2024-05-01 23:44:15 +0200
commitdf1a6c725939ae5ff026f6a4333d7aa94608430d (patch)
tree87675dff82034df510d62578407e8f322e2e5da3
parentaae603980b816023a1f6d782bc421d38104a4e62 (diff)
downloadguix-df1a6c725939ae5ff026f6a4333d7aa94608430d.tar.gz
gnu: scilab: Cleanup.
* gnu/packages/maths.scm (scilab):
  [arguments]<#:phases>: In pre-build phase, remove unecessary
  code, due to the former introduction of the rewrap-scilab-cli
  phase. More robust version setting in the set-version phase. It
  anticipates for the next release which will not use "main" anymore.
  [source]<origin>(snippet) Sort dynamic_link deleted files.
  [inputs]: Add bash-minimal.

Change-Id: I49b17886405e1ed8161e71b51655fa393ff7f10b
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 361f2f7b68..3ce67cc0ba 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9768,9 +9768,9 @@ computation is supported via MPI.")
                "compile"
                "config.guess"
                "config.sub"
-               "ltmain.sh"
                "depcomp"
                "install-sh"
+               "ltmain.sh"
                "missing"))
             (delete-file-recursively "modules/dynamic_link/src/scripts/m4")
             (for-each delete-file
@@ -9794,6 +9794,7 @@ computation is supported via MPI.")
     (inputs (list `(,pcre "bin")
                   `(,pcre "out")
                   arpack-ng
+                  bash-minimal
                   curl
                   fftw
                   gettext-minimal
@@ -9851,10 +9852,8 @@ computation is supported via MPI.")
             (add-after 'unpack 'set-version
               (lambda _
                 (substitute* "modules/core/includes/version.h.in"
-                  (("scilab-branch-main")  ; version
-                   (string-append
-                    "scilab-"
-                    #$(version-major+minor (package-version this-package)))))))
+                  (("branch-[a-z0-9\\.]*")  ; version
+                   #$(version-major+minor (package-version this-package))))))
             (add-after 'unpack 'restrain-to-scilab-cli
               (lambda _
                 ;; Install only scilab-cli.desktop
@@ -9888,10 +9887,6 @@ computation is supported via MPI.")
                   ((assoc-ref %standard-phases 'bootstrap)))))
             (add-before 'build 'pre-build
               (lambda* (#:key inputs #:allow-other-keys)
-                ;; Fix scilab script.
-                (substitute* "bin/scilab"
-                  (("/bin/ls")
-                   (search-input-file inputs "bin/ls")))
                 ;; Fix core.start.
                 (substitute* "modules/core/etc/core.start"
                   (("'SCI/modules")