summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:45:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:19 +0200
commite3439ca7ec26fd5d4b1fe89317a5e2f02fa44786 (patch)
tree5d2a60da1d3b235e82aa34a1ae3b07c8f9238808
parent8323550054ccfc89242fbab156d18c9c2d55315c (diff)
downloadguix-e3439ca7ec26fd5d4b1fe89317a5e2f02fa44786.tar.gz
gnu: Add texlive-sankey.
* gnu/packages/tex.scm (texlive-sankey): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a8523ef170..0ef0e62c99 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5908,6 +5908,26 @@ package solves the problem by extending ideas described in M. I. Grinchuk
 mathematical packages.")
     (license license:lppl1.3+)))
 
+(define-public texlive-sankey
+  (package
+    (name "texlive-sankey")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/sankey/" "source/latex/sankey/"
+                   "tex/latex/sankey/")
+             (base32
+              "020in4r4pim07nya119767zjs90yqpkcyr6h6l5v7ig21n4q7d8s")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/sankey")
+    (synopsis "Draw Sankey diagrams with TikZ")
+    (description
+     "This package provides macros and an environment for creating Sankey
+diagrams, i.e., flow diagrams in which the width of the arrows is proportional
+to the flow rate.")
+    (license (list license:lppl1.3+ license:gpl3+))))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")