summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:07:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:51 +0200
commite3e6dde662823730c0f42d418c6dff058d24f597 (patch)
tree9034a6610f34d13a16cd197727e98bcbea639246
parent98076e197f5de67858edd3fe3550f5f30bce5535 (diff)
downloadguix-e3e6dde662823730c0f42d418c6dff058d24f597.tar.gz
gnu: Add texlive-chessboard.
* gnu/packages/tex.scm (texlive-chessboard): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f3c5c72f0b..8b1db254c3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4237,6 +4237,28 @@ fairy chess problems (mostly using rotated images of pieces) and other
 boards.")
     (license license:lppl1.2+)))
 
+(define-public texlive-chessboard
+  (package
+    (name "texlive-chessboard")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/chessboard/"
+                   "source/latex/chessboard/"
+                   "tex/latex/chessboard/")
+             (base32
+              "1nz66h6baz5m2jfzjzyccw0rcpkc6rfbq9cc759y875b47j8pkhx")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/chessboard")
+    (synopsis "Print chess boards")
+    (description
+     "This package offers commands to print chessboards.  It can print partial
+boards, hide pieces and fields, color the boards and put various marks on the
+board.  It has a lot of options to place pieces on the board.  Using exotic
+pieces (e.g., for fairy chess) is possible.")
+    (license license:lppl)))
+
 (define-public texlive-chhaya
   (package
     (name "texlive-chhaya")