summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-26 22:06:57 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 21:33:44 +0100
commite582f27a53ffb816f807e6e0014fcfca9d92c226 (patch)
tree4aaf0a37fda49a9354aee847845f3607192b8d98
parent243ff411958759c941f90362c178ab073b1b5ada (diff)
downloadguix-e582f27a53ffb816f807e6e0014fcfca9d92c226.tar.gz
gnu: Add go-github-com-msteinert-pam-v2.
* gnu/packages/golang-xyz.scm (go-github-com-msteinert-pam-v2): New variable.

Change-Id: I7dfcb72703722f894eb52c603f02e64e7350f53a
-rw-r--r--gnu/packages/golang-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f0e31ed732..0cde48ad9e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2562,6 +2562,26 @@ multibase} (self identifying base encodings) in Go.")
 Authentication Modules, PAM} application API.")
     (license license:bsd-2)))
 
+(define-public go-github-com-msteinert-pam-v2
+  (package
+    (inherit go-github-com-msteinert-pam)
+    (name "go-github-com-msteinert-pam-v2")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/msteinert/pam")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1h02dcx00vgcsxgl5sly82dbixk8cimjb10q5p405bf4fz8z7q6k"))))
+    (arguments
+     (substitute-keyword-arguments
+         (package-arguments go-github-com-msteinert-pam)
+       ((#:import-path _ "github.com/msteinert/pam")
+        "github.com/msteinert/pam/v2")))))
+
 (define-public go-github-com-multiformats-go-multicodec
   (package
     (name "go-github-com-multiformats-go-multicodec")