summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:39:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:49:40 +0200
commite6ec657c497cdfe9130b7bf5bdfb717a823bf02b (patch)
treeb08f365a0aea32c10976e7229c90dcf803cd98fa
parent5a0e4b60d36f6748eca19f5f8cb3161c577b1f7e (diff)
downloadguix-e6ec657c497cdfe9130b7bf5bdfb717a823bf02b.tar.gz
gnu: u-boot-tools: Honor the #:tests flag.
* gnu/packages/bootloaders.scm (u-boot-tools)[arguments]: Adjust the
custom 'check and 'check-x86 phases to honor the #:tests? flag.

Change-Id: I663eba70df61569928e167ffe1af9411e405da80
-rw-r--r--gnu/packages/bootloaders.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index fcc1088fd6..52a077ecea 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -926,19 +926,22 @@ CONFIG_TOOLS_LIBCRYPTO=n")
                            "tools/sunxi-spl-image-builder")))))
          (delete 'check)
          (add-after 'install 'check
-           (lambda* (#:key make-flags test-target #:allow-other-keys)
-             (invoke "test/image/test-imagetools.sh")))
+           (lambda* (#:key make-flags test-target tests? #:allow-other-keys)
+             (when tests?
+               (invoke "test/image/test-imagetools.sh"))))
          ;; Only run full test suite on x86_64 systems, as many tests
          ;; assume x86_64.
          ,@(if (string-match "^x86_64-linux"
                              (or (%current-target-system)
                                  (%current-system)))
                '((add-after 'check 'check-x86
-                   (lambda* (#:key make-flags test-target #:allow-other-keys)
-                     (apply invoke "make" "mrproper" make-flags)
-                     (setenv "SDL_VIDEODRIVER" "dummy")
-                     (setenv "PAGER" "cat")
-                     (apply invoke "make" test-target make-flags))))
+                   (lambda* (#:key make-flags test-target tests? #:allow-other-keys)
+                     (when tests?
+                       (begin
+                         (apply invoke "make" "mrproper" make-flags)
+                         (setenv "SDL_VIDEODRIVER" "dummy")
+                         (setenv "PAGER" "cat")
+                         (apply invoke "make" test-target make-flags))))))
                '()))))
     (description (string-append
                   (package-description u-boot)