summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:46:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:31 +0200
commite7e320c24dba5b6184754d2978ac1cf96643d1e9 (patch)
treebac74507db37e043b59a3a5ffbb53a32bd022dbd
parentdad815d74385711db9327c8d8618bb9d9c39fd5e (diff)
downloadguix-e7e320c24dba5b6184754d2978ac1cf96643d1e9.tar.gz
gnu: Add texlive-notomath.
* gnu/packages/tex.scm (texlive-notomath): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 06b5d60fed..8f56d88b21 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19819,6 +19819,29 @@ generate bibliographies to be served on the web starting from BibTeX files.")
 version.")
     (license license:silofl1.1)))
 
+(define-public texlive-notomath
+  (package
+    (name "texlive-notomath")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/notomath/"
+                   "fonts/map/dvips/notomath/"
+                   "fonts/tfm/public/notomath/"
+                   "fonts/type1/public/notomath/"
+                   "fonts/vf/public/notomath/"
+                   "tex/latex/notomath/")
+             (base32
+              "1m7b7blmbc6ypv737qhav6np3ri1a7cl14wnhpd5bgs89v9mkafd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/notomath")
+    (synopsis "Math support for Noto fonts")
+    (description
+     "This package provides math support via @code{newtxmath} for NotoSerif
+and NotoSans.  (Regular and Bold weights only.)")
+    (license (list license:silofl1.1 license:lppl1.3+))))
+
 (define-public texlive-nuc
   (package
     (name "texlive-nuc")