summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-25 14:39:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:42 +0300
commite855da63b458c0cd855aab9be6610e013f6211c0 (patch)
tree447e25b11f37a6febefda24af21be58f45c3681f
parent4c51d30199736859e83412122df1dfa5fa37bd50 (diff)
downloadguix-e855da63b458c0cd855aab9be6610e013f6211c0.tar.gz
gnu: rust-hashbrown-0.8: Update to 0.8.2.
* gnu/packages/crates-io.scm (rust-hashbrown-0.8): Update to 0.8.2.
[source]: Add snippet to allow newer versions of rustc-hash.
[cargo-inputs]: Add rust-autocfg-1.
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 571aeaa75e..641c341f11 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26572,18 +26572,23 @@ hash map.")
   (package
     (inherit rust-hashbrown-0.9)
     (name "rust-hashbrown")
-    (version "0.8.0")
+    (version "0.8.2")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "hashbrown" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "09y86zmf59n6ys9yf2bvg9ckwwa1ijv2i3flkz45iqkwfmh7i6xb"))))
+        (base32 "09cckr5l71ypvfdbvv1qsag4222blixwn9300hpbr831j3vn46z9"))
+    (modules '((guix build utils)))
+    (snippet
+     '(begin (substitute* "Cargo.toml"
+               (("=1\\.0") "^1.0"))))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-ahash" ,rust-ahash-0.3)
+        ("rust-autocfg" ,rust-autocfg-1)
         ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
         ("rust-rayon" ,rust-rayon-1)
         ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)