summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-15 16:20:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:32:27 -0400
commite89704d84ac30c739e780a5869bf8add50f407cc (patch)
tree5171c9a03789219f371bd74e06822d39211f827d
parent70fed689c0b8b0f52ff8e5d008a82ab9d9fb596c (diff)
downloadguix-e89704d84ac30c739e780a5869bf8add50f407cc.tar.gz
gnu: qtwayland-5: Update to 5.15.10.
* gnu/packages/qt.scm (qtwayland-5): Update to 5.15.10.
[source]: Remove qtwayland-gcc-11.patch patch.
* gnu/packages/patches/qtwayland-gcc-11.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/qtwayland-gcc-11.patch18
-rw-r--r--gnu/packages/qt.scm7
3 files changed, 3 insertions, 23 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6e2f70cdaa..eb6f622349 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1880,7 +1880,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/quagga-reproducible-build.patch          \
   %D%/packages/patches/quickswitch-fix-dmenu-check.patch	\
   %D%/packages/patches/quilt-grep-compat.patch 			\
-  %D%/packages/patches/qtwayland-gcc-11.patch			\
   %D%/packages/patches/qtwayland-dont-recreate-callbacks.patch	\
   %D%/packages/patches/qtwayland-cleanup-callbacks.patch	\
   %D%/packages/patches/ragel-char-signedness.patch		\
diff --git a/gnu/packages/patches/qtwayland-gcc-11.patch b/gnu/packages/patches/qtwayland-gcc-11.patch
deleted file mode 100644
index 06983ff2f3..0000000000
--- a/gnu/packages/patches/qtwayland-gcc-11.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Add missing import for newer libstdc++.
-
-Taken from upstream:
-
-  https://github.com/qt/qtwayland/commit/1aa6ec2c778504d96543f6cdc2b9199a7b066fc1
-
-diff --git a/tests/auto/client/shared/corecompositor.cpp b/tests/auto/client/shared/corecompositor.cpp
-index 5c6c83baa..fa9b7662a 100644
---- a/tests/auto/client/shared/corecompositor.cpp
-+++ b/tests/auto/client/shared/corecompositor.cpp
-@@ -27,6 +27,7 @@
- ****************************************************************************/
- 
- #include "corecompositor.h"
-+#include <thread>
- 
- namespace MockCompositor {
- 
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9194895c2f..54b138c0d0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1729,16 +1729,15 @@ set of plugins for interacting with pulseaudio and GStreamer.")
   (package
     (inherit qtsvg-5)
     (name "qtwayland")
-    (version "5.15.8")
+    (version "5.15.10")
     (source (origin
               (method url-fetch)
               (uri (qt-url name version))
-              (patches (search-patches "qtwayland-gcc-11.patch"
-                                       "qtwayland-dont-recreate-callbacks.patch"
+              (patches (search-patches "qtwayland-dont-recreate-callbacks.patch"
                                        "qtwayland-cleanup-callbacks.patch"))
               (sha256
                (base32
-                "0aa5jcvvap6qca6imdkhs1mhv5bnaxn466mmpl7x78jx1za7n3ps"))))
+                "1w9nclz1lfg5haq3m6ihils0kl2n1pqagdyh71ry1m281w8gvly8"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg-5)
        ((#:phases phases)