summary refs log tree commit diff
diff options
context:
space:
mode:
authorWinter <winter@winter.cafe>2023-02-26 22:22:33 -0500
committerTobias Geerinckx-Rice <me@tobias.gr>2023-02-26 01:00:09 +0100
commitea870a70e93e7ea93e35fa8e0afc3cfdb1b66ba2 (patch)
treec8d6a817f370a88815573286b838e84b1779e282
parent4ef9a5dd5ec07d2cf4326b65d44a9227d184a56e (diff)
downloadguix-ea870a70e93e7ea93e35fa8e0afc3cfdb1b66ba2.tar.gz
gnu: fish: Update to 3.6.0.
* gnu/packages/shells.scm (fish): Update to 3.6.0.
[source]: Remove snippet, as the bundled PCRE2 sources have been
removed (see CHANGELOG.rst).

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/shells.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 0c8cbf3f4c..da2455e345 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -118,7 +118,7 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
 (define-public fish
   (package
     (name "fish")
-    (version "3.5.1")
+    (version "3.6.0")
     (source
      (origin
        (method url-fetch)
@@ -126,15 +126,10 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
                            "releases/download/" version "/"
                            "fish-" version ".tar.xz"))
        (sha256
-        (base32 "0a39vf0wqq6asw5xcrwgdsc67h5bxkgxzy77f8bx6pd4qlympm56"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Remove bundled software.
-           (delete-file-recursively "pcre2")))))
+        (base32 "10b1xa1hpmi62rzh3qgxlw7xrhyigs8kssagccawmrryfxbls14p"))))
     (build-system cmake-build-system)
     (inputs
-     (list fish-foreign-env ncurses pcre2 ; don't use the bundled PCRE2
+     (list fish-foreign-env ncurses pcre2
            python))  ; for fish_config and manpage completions
     (native-inputs
      (list doxygen groff ; for 'fish --help'