summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 11:31:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:56 +0000
commiteb23cceba53a491272372a7ec4a077b603520905 (patch)
tree6fd7802824c120119c36f8941c8c91fe1f4aaf33
parent40c01f8dd3b8ab3f093838b1915a50ce74fd56c2 (diff)
downloadguix-eb23cceba53a491272372a7ec4a077b603520905.tar.gz
gnu: go-github-com-subosito-gotenv: Update to 1.6.0.
* gnu/packages/golang.scm (go-github-com-subosito-gotenv): Update to 1.6.0.
[propagated-inputs]: Add go-golang-org-x-text.

Change-Id: I6010bdacf80eaf6aa2cf869844b2327124318580
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9799ce6d6b..acd125e9b9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3378,7 +3378,7 @@ updating files, like @command{tail -f}.")
 (define-public go-github-com-subosito-gotenv
   (package
     (name "go-github-com-subosito-gotenv")
-    (version "1.2.0")
+    (version "1.6.0")
     (source
      (origin
        (method git-fetch)
@@ -3388,12 +3388,14 @@ updating files, like @command{tail -f}.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0mav91j7r4arjkpq5zcf9j74f6pww8ic53x43wy7kg3ibw31yjs5"))))
+         "0h7kb9mc67rl16kvls2d16pimdrz59l5x4l002qsv2p2766mpjif"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/subosito/gotenv"))
     (native-inputs
      (list go-github-com-stretchr-testify))
+    (propagated-inputs
+     (list go-golang-org-x-text))
     (home-page "https://github.com/subosito/gotenv")
     (synopsis "Go library for loading environment variables from files")
     (description "Go library for loading environment variables from files")