summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-03 21:42:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:12 +0100
commitee75a0c0d8a87a6c542193c997c6f1923617e7f1 (patch)
treefb08ab6daeb230efc3b1b139facbce0e7738710c
parentfbece5a8e0f55d00c91edf082d01e1f9778a0913 (diff)
downloadguix-ee75a0c0d8a87a6c542193c997c6f1923617e7f1.tar.gz
gnu: python-skyfield: Enable tests.
* gnu/packages/astronomy.scm (python-skyfield): Enable tests.
[source]: Swap to git checkout containing test data.
[build-system]: Swap to pyproject-build-system.
[native-inputs]: Add python-assay and python-pandas.

Change-Id: Ia4604ab2e44860dcf1294688639d3c54881f8d8c
-rw-r--r--gnu/packages/astronomy.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3dee5a5a53..4d719c8a22 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5050,15 +5050,27 @@ astronomical images, especially when there is no WCS information available.")
     (version "1.48")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "skyfield" version))
+       (method git-fetch) ; PyPI tarball lacks test data
+       (uri (git-reference
+             (url "https://github.com/skyfielders/python-skyfield")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1qaz0k0lkni3y423r66mkvj99bx08qa9xgqp3cs2df70cmdz30cb"))))
-    (build-system python-build-system)
+        (base32 "0l324r4pz7d5w72c7c5akvjx40287hl7sl0qv7swvn2da53vmq0r"))))
+    (build-system pyproject-build-system)
     (arguments
-     ;; XXX: Tests depend on custom test framework
-     ;; https://github.com/brandon-rhodes/assay
-     `(#:tests? #f))
+     (list
+      #:test-flags
+      #~(list "-m" "assay" "--batch" "skyfield.tests")
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? test-flags #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion "ci"
+                  (apply invoke "python" test-flags))))))))
+    (native-inputs
+     (list python-assay python-pandas))
     (propagated-inputs
      (list python-certifi
            python-jplephem