summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 22:02:54 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:44 +0200
commitf0c22c142759a533ce9f8ce4c28f5d3b4e23fee8 (patch)
tree0edcb6e443bf4db615744ae02eaa5149f18b0591
parentd56532c568d66c4b38552c0c96777d4b770374a2 (diff)
downloadguix-f0c22c142759a533ce9f8ce4c28f5d3b4e23fee8.tar.gz
gnu: global: Adjust order of phases.
* gnu/packages/code.scm (global)[arguments]: Adjust the order of the
phases so that they get read in the correct order.

Change-Id: I149ccd249821c64aa5a508048d995e9963ea4c08
-rw-r--r--gnu/packages/code.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 03a04323b0..3f7a6de478 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -225,22 +225,6 @@ highlighting your own code that seemed comprehensible when you wrote it.")
                    (substitute* "globash/globash.in"
                      (("/bin/echo")
                       (search-input-file inputs "bin/echo")))))
-               (add-after 'post-install 'install-plugins
-                 (lambda _
-                   (with-directory-excursion "plugin-factory"
-                     (invoke "make" "install"))))
-               (add-before 'install 'dont-install-to-/var
-                 (lambda _
-                   (substitute* "gozilla/Makefile"
-                     (("DESTDIR\\)\\$\\{localstatedir\\}")
-                      "TMPDIR)"))))
-               (add-after 'install-plugins 'wrap-program
-                 (lambda _
-                   (wrap-program
-                       (string-append #$output
-                                      "/share/gtags/script/pygments_parser.py")
-                     `("GUIX_PYTHONPATH" ":" prefix
-                       (,(getenv "GUIX_PYTHONPATH"))))))
                (add-after 'install 'post-install
                  (lambda _
                    ;; Install the plugin files in the right place.
@@ -258,7 +242,23 @@ highlighting your own code that seemed comprehensible when you wrote it.")
                      (rename-file (string-append data "/gtags.vim")
                                   (string-append vim  "/gtags.vim"))
                      (rename-file (string-append data "/gtags-cscope.vim")
-                                  (string-append vim  "/gtags-cscope.vim"))))))))
+                                  (string-append vim  "/gtags-cscope.vim")))))
+               (add-after 'post-install 'install-plugins
+                 (lambda _
+                   (with-directory-excursion "plugin-factory"
+                     (invoke "make" "install"))))
+               (add-before 'install 'dont-install-to-/var
+                 (lambda _
+                   (substitute* "gozilla/Makefile"
+                     (("DESTDIR\\)\\$\\{localstatedir\\}")
+                      "TMPDIR)"))))
+               (add-after 'install-plugins 'wrap-program
+                 (lambda _
+                   (wrap-program
+                       (string-append #$output
+                                      "/share/gtags/script/pygments_parser.py")
+                     `("GUIX_PYTHONPATH" ":" prefix
+                       (,(getenv "GUIX_PYTHONPATH")))))))))
     (inputs
       (list bash-minimal                ; for wrap-program
             coreutils