summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-23 17:09:01 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-12 17:41:38 +0900
commitf0c27b2fa824a43bc6a6d056ec7a7c5c78c3a367 (patch)
tree3edddb52f2f962ab54f316f5f63a1b6667f88db8
parentcd72e4338826cd4786309a7e7c09c2aaf0b04af3 (diff)
downloadguix-f0c27b2fa824a43bc6a6d056ec7a7c5c78c3a367.tar.gz
gnu: plib: Build with -fPIC.
* gnu/packages/game-development.scm (plib)
[arguments] <#:configure-flags>: New argument.
[inputs]: Move field after...
[native-inputs]: ... this one.

Change-Id: Ieddfb8814632f74c98d0e2cda949709b718c7a0d
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 6100e4e94e..89c6c0b75e 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2554,10 +2554,12 @@ joystick support.")))
               (patches (search-patches "plib-CVE-2011-4620.patch"
                                        "plib-CVE-2012-4552.patch"))))
     (build-system gnu-build-system)
-    (inputs
-     (list mesa libxi libxmu))
-    (native-inputs
-     (list pkg-config))
+    ;; plib exists only as a static library, per the author's choice (see:
+    ;; https://sourceforge.net/p/plib/mailman/message/10289018/).  Build it
+    ;; with PIC, so that shared programs can at least "link" to it.
+    (arguments (list #:configure-flags #~(list "CXXFLAGS=-fPIC")))
+    (native-inputs (list autoconf automake pkg-config))
+    (inputs (list mesa libxi libxmu))
     (home-page "https://plib.sourceforge.net/")
     (synopsis "Suite of portable game libraries")
     (description "PLIB is a set of libraries that will permit programmers to