summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 13:08:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:53 +0200
commitf273cf58439b6fc6800a28218749ba710e4594a7 (patch)
tree65ad06961e833235ab29ea221df09df57133b86e
parent7c2013dcc9acc7dec5152e0efd8d4eb143ce31b1 (diff)
downloadguix-f273cf58439b6fc6800a28218749ba710e4594a7.tar.gz
gnu: Add texlive-wsuipa.
* gnu/packages/tex.scm (texlive-wsuipa): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f6f381d37e..66c3bdf5f7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25983,6 +25983,35 @@ Native American languages.")
      "This package provides LaTeX support for the @code{wnri} fonts.")
     (license license:gpl2)))
 
+(define-public texlive-wsuipa
+  (package
+    (name "texlive-wsuipa")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/wsuipa/"
+                   "fonts/source/public/wsuipa/"
+                   "fonts/tfm/public/wsuipa/"
+                   "tex/latex/wsuipa/")
+             (base32
+              "0gj7d68gb82dxmrbz69ibgpw2q2h6sb22k8nl569r27m2sli60jy")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    ;; FIXME: Font metrics generation fails with "! Strange path (turning
+    ;; number is zero)" error.
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (delete 'generate-font-metrics))))
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/wsuipa")
+    (synopsis "International Phonetic Alphabet fonts")
+    (description
+     "The package provides a 7-bit IPA font, as Metafont source, and macros
+for support under TeXt1 and LaTeX.  The fonts (and macros) are now largely
+superseded by the @code{tipa} fonts.")
+    (license license:knuth)))
+
 (define-public texlive-xcite
   (package
     (name "texlive-xcite")