summary refs log tree commit diff
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2024-07-31 14:46:40 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2024-08-05 17:20:52 +0900
commitf2e159665b00933a5bacc3053b4631826231940f (patch)
treef111e823260567fad53e0abceda504b35c2b237a
parent3c309a7b7020a9645bfe775d9f53f43f05d076bf (diff)
downloadguix-f2e159665b00933a5bacc3053b4631826231940f.tar.gz
gnu: Add zycore.
* gnu/packages/engineering.scm (zycore): New variable.

Change-Id: Ia38413f43bc667a9a12916d3f0e786e06f6d358f
-rw-r--r--gnu/packages/engineering.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index d5d72a0c85..3316464e03 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -40,6 +40,7 @@
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
 ;;; Copyright © 2024 Juliana Sims <juli@incana.org>
+;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1926,6 +1927,29 @@ like relocation symbols.  It is able to deal with malformed binaries, making
 it suitable for security research and analysis.")
     (license license:lgpl3)))
 
+(define-public zycore
+  (package
+    (name "zycore")
+    (version "1.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/zyantific/zycore-c")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32 "0s962pkqybh1xbs75y4jb4bqc9qnq0sviqd570mirqdhhq87agib"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (native-inputs (list googletest))
+    (arguments `(#:configure-flags '("-DZYCORE_BUILD_SHARED_LIBS=ON"
+                                     "-DZYCORE_BUILD_TESTS=ON")))
+    (home-page "https://github.com/zyantific/zycore-c")
+    (synopsis "Internal library for Zydis.")
+    (description
+     "This package provides platfrom-independent types, macros
+and a fallback for environments without libc for Zydis.")
+    (license license:expat)))
+
 (define-public asco
   (package
     (name "asco")