summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-22 20:54:09 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 21:31:58 +0000
commitf427ec7026110e74cb36b506f5eb4c52fa556079 (patch)
tree26a4f003932fdbe28d196f12fa7099d571e6ff76
parentc2c1098585b10f42bed7647f2130a2727c0488f8 (diff)
downloadguix-f427ec7026110e74cb36b506f5eb4c52fa556079.tar.gz
gnu: go-github-com-kballard-go-shellquote: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-kballard-go-shellquote):
Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/xdisorg.scm: Remove (gnu packages syncthing).
Add (gnu packages golang-xyz).

Change-Id: I3ab4cbc55d8ca0ad8b7fec0130bdb935039f2841
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/syncthing.scm24
-rw-r--r--gnu/packages/xdisorg.scm2
3 files changed, 28 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8b100ce30a..84b17a1390 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1249,6 +1249,33 @@ customized globally.")
 database/sql package.")
     (license license:expat)))
 
+(define-public go-github-com-kballard-go-shellquote
+  ;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
+  (let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")
+        (revision "1"))
+    (package
+      (name "go-github-com-kballard-go-shellquote")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/kballard/go-shellquote")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1rspvmnsikdq95jmx3dykxd4k1rmgl98ryjrysvl0cf18hl1vq80"))))
+      (build-system go-build-system)
+      (arguments
+       (list
+        #:import-path "github.com/kballard/go-shellquote"))
+      (synopsis "Shell-style string joins and splits")
+      (description
+       "Shellquote provides utilities for joining/splitting strings using sh's
+word-splitting rules.")
+      (home-page "https://github.com/kballard/go-shellquote")
+      (license license:expat))))
+
 (define-public go-github-com-matryer-try
   (package
     (name "go-github-com-matryer-try")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 779e921d65..4d2f7ef9f0 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -633,30 +633,6 @@ the current goroutine's ID.")
       (home-page "https://github.com/petermattis/goid")
       (license asl2.0))))
 
-(define-public go-github-com-kballard-go-shellquote
-  (let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")
-        (revision "1"))
-    (package
-      (name "go-github-com-kballard-go-shellquote")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/kballard/go-shellquote")
-                       (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1rspvmnsikdq95jmx3dykxd4k1rmgl98ryjrysvl0cf18hl1vq80"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/kballard/go-shellquote"))
-      (synopsis "Shell-style string joins and splits")
-      (description "Shellquote provides utilities for joining/splitting strings
-using sh's word-splitting rules.")
-      (home-page "https://github.com/kballard/go-shellquote")
-      (license expat))))
-
 (define-public go-github-com-syncthing-notify
   (let ((commit "69c7a957d3e261f9744f46b3dd4d608d8480ad90")
         (revision "5"))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 15f8b7c624..f502df6d02 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -115,6 +115,7 @@
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages golang)
+  #:use-module (gnu packages golang-xyz)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
@@ -140,7 +141,6 @@
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages sphinx)
-  #:use-module (gnu packages syncthing)
   #:use-module (gnu packages tex)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tcl)