summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 23:54:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 23:55:11 +0100
commitf7e0bb055fcf79244e6d318298fdf92ec6ce2350 (patch)
tree7e22c83260afd546cd4a1724d3d37047864d5b3d
parent044142b15bec9ef5e13d37cba78b32470c928cda (diff)
downloadguix-f7e0bb055fcf79244e6d318298fdf92ec6ce2350.tar.gz
gnu: Remove go-github-com-ipfs-go-ipfs-api.
Unmaintained: "This package is no longer being maintained. Please use
kubo/client/rpc instead.  This repository has been archived by the owner
on Feb 7, 2024. It is now read-only."

* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-api): Delete variable.

Change-Id: I270f92a863739dfb038a7762dc55080e3610bebe
-rw-r--r--gnu/packages/ipfs.scm48
1 files changed, 0 insertions, 48 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 79662cf9ca..022b435a48 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -685,54 +685,6 @@ batteries-included codec implementations of IPLD for CBOR and JSON, and tooling
 basic operations on IPLD objects (traversals, etc).")
     (license license:expat)))
 
-(define-public go-github-com-ipfs-go-ipfs-api
-  (let ((commit
-          "dafc2a13a4389ac1a6c2786e34ab70a4f26d3a3f")
-        (revision "0"))
-    (package
-      (name "go-github-com-ipfs-go-ipfs-api")
-      (version (git-version "1.3.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/ipfs/go-ipfs-api")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "06kibnwb037sqynk99j07wm8alvxwx3bari9gdax4jv93396kycj"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/ipfs/go-ipfs-api"
-         ;; TODO: Tests fail, might need network access.
-         #:tests? #f))
-      (native-inputs
-       (list go-github-com-ipfs-go-ipfs-cmdkit-files
-             go-github-com-libp2p-go-libp2p-metrics
-             go-github-com-libp2p-go-flow-metrics
-             go-github-com-libp2p-go-libp2p-peer
-             go-github-com-libp2p-go-libp2p-protocol
-             go-github-com-libp2p-go-libp2p-crypto
-             go-github-com-mitchellh-go-homedir
-             go-github-com-multiformats-go-multiaddr
-             go-github-com-multiformats-go-multiaddr-net
-             go-github-com-btcsuite-btcd-btcec
-             go-github-com-gogo-protobuf
-             go-github-com-minio-blake2b-simd
-             go-github-com-minio-sha256-simd
-             go-github-com-mr-tron-base58
-             go-github-com-multiformats-go-multihash
-             go-golang-org-x-crypto
-             go-github-com-spaolacci-murmur3
-             go-github-com-gxed-hashland-keccakpg
-             go-github-com-whyrusleeping-tar-utils
-             go-github-com-cheekybits-is))
-      (home-page "https://github.com/ipfs/go-ipfs-api")
-      (synopsis "Unofficial Go interface to IPFS's HTTP API")
-      (description "An unofficial Go interface to IPFS's HTTP API")
-      (license license:expat))))
-
 (define-public go-github-com-ipfs-go-log-v2
   (package
     (name "go-github-com-ipfs-go-log-v2")