summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2022-01-19 20:27:03 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-21 00:11:52 +0100
commitfd11441371cfbfcd0a2173ceff519e0ea6e1e973 (patch)
treeb2ad9b164fa43d0755c667fd4fc8982bc3038aa8
parent8b85d0354fdd61e9d3c7f8983103067155323a28 (diff)
downloadguix-fd11441371cfbfcd0a2173ceff519e0ea6e1e973.tar.gz
gnu: Add rust-rowan-0.15.
* gnu/packages/crates-io.scm (rust-rowan-0.15): New variable.
(rust-rowan-0.13): Inherit from above.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm75
1 files changed, 50 insertions, 25 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 77e41ff8fd..3c258aee62 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45288,39 +45288,64 @@ can handle huge texts and memory-incoherent edits with ease.")
 wildcard segments")
     (license license:expat)))
 
-(define-public rust-rowan-0.13
+(define-public rust-rowan-0.15
   (package
     (name "rust-rowan")
-    (version "0.13.0-pre.6")
+    (version "0.15.2")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "rowan" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32
-            "03gh3wa52135mh1an1x4hw6jba64fwfsh4lw3fsmm6jy2i7c1k42"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rowan" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ilxrar5npwnsb575gxh2gp8hi3032mm20sapzw72sv58gn8zski"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:skip-build? #t
-        #:cargo-inputs
-        (("rust-countme" ,rust-countme-2)
-         ("rust-hashbrown" ,rust-hashbrown-0.9)
-         ("rust-memoffset" ,rust-memoffset-0.6)
-         ("rust-rustc-hash" ,rust-rustc-hash-1)
-         ("rust-serde" ,rust-serde-1)
-         ("rust-text-size" ,rust-text-size-1))
-        #:cargo-development-inputs
-        (("rust-m-lexer" ,rust-m-lexer-0.0.4))))
-    (home-page
-      "https://github.com/rust-analyzer/rowan")
-    (synopsis
-      "Library for generic lossless syntax trees")
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-countme" ,rust-countme-3)
+        ("rust-hashbrown" ,rust-hashbrown-0.11)
+        ("rust-memoffset" ,rust-memoffset-0.6)
+        ("rust-rustc-hash" ,rust-rustc-hash-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-text-size" ,rust-text-size-1))
+       #:cargo-development-inputs
+       (("rust-m-lexer" ,rust-m-lexer-0.0.4))))
+    (home-page "https://github.com/rust-analyzer/rowan")
+    (synopsis "Library for generic lossless syntax trees")
     (description
-      "This package provides a library for generic lossless syntax trees.")
+     "This package provides a library for generic lossless syntax trees.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-rowan-0.13
+  (package
+    (inherit rust-rowan-0.15)
+    (name "rust-rowan")
+    (version "0.13.0-pre.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rowan" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "03gh3wa52135mh1an1x4hw6jba64fwfsh4lw3fsmm6jy2i7c1k42"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-countme" ,rust-countme-2)
+        ("rust-hashbrown" ,rust-hashbrown-0.9)
+        ("rust-memoffset" ,rust-memoffset-0.6)
+        ("rust-rustc-hash" ,rust-rustc-hash-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-text-size" ,rust-text-size-1))
+       #:cargo-development-inputs
+       (("rust-m-lexer" ,rust-m-lexer-0.0.4))))))
+
 (define-public rust-rsa-0.5
   (package
     (name "rust-rsa")