summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-08-25 01:13:41 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2023-08-25 01:14:44 +0200
commitff48a10807162233f32010420e96752d6744c6b8 (patch)
treeebafacfd6fe5ecfc7467ed37004ab4ea0d205a3a
parent2c4131ebb3cf2a5eba4fb063e6f62f5bc7c814b3 (diff)
downloadguix-ff48a10807162233f32010420e96752d6744c6b8.tar.gz
gnu: ebusd: Default pidfile and logfile to writable locations.
* gnu/packages/embedded.scm (ebusd)[arguments]<#:configure-flags>: Specify
--localstatedir=/var
-rw-r--r--gnu/packages/embedded.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 1250c2eff0..325013a627 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1472,7 +1472,8 @@ debugging them, and more.")
                 "1zqnxk6vgszlf410pypsjjliiy9wawy585fm7v25mka47i6iqafq"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("--localstatedir=/var")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'install 'install-config
            (lambda* (#:key inputs outputs #:allow-other-keys)